aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-07-26 16:08:35 -0400
committerMark H Weaver <mhw@netris.org>2014-07-26 16:08:35 -0400
commitf8984634fdabc9969bacba754a4cbc2d8738c477 (patch)
treecd6bc10684257c0d4fd6dd2e234e6d1e3acb3ce0 /gnu/packages/admin.scm
parentff838e2ce64dccd79ad275d4fc314f7f0feb9947 (diff)
downloadguix-f8984634fdabc9969bacba754a4cbc2d8738c477.tar.gz
guix-f8984634fdabc9969bacba754a4cbc2d8738c477.zip
gnu: sudo: Apply workaround to build system for MIPS.
* gnu/packages/admin.scm (sudo): Work around the fact that configure fails on MIPS without 'file'.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 46f5cc8a58..4a88fdd76a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -630,7 +630,7 @@ system administrator.")
"002l6h27pnhb77b65frhazbhknsxvrsnkpi43j7i0qw1lrgi7nkf"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--with-logpath=/var/log/sudo.log")
+ `(#:configure-flags '("--with-logpath=/var/log/sudo.log")
#:phases (alist-cons-before
'configure 'pre-configure
(lambda _
@@ -644,7 +644,18 @@ system administrator.")
"")
(("^install: (.*)install-sudoers(.*)" _ before after)
;; Don't try to create /etc/sudoers.
- (string-append "install: " before after "\n"))))
+ (string-append "install: " before after "\n")))
+
+ ;; XXX FIXME sudo 1.8.10p3 was bootstrapped with a
+ ;; prerelease libtool, which fails on MIPS in the absence
+ ;; of /usr/bin/file. As a temporary workaround, we patch
+ ;; the configure script to hardcode use of the little
+ ;; endian N32 ABI on MIPS.
+ ,@(if (equal? "mips64el-linux" (or (%current-target-system)
+ (%current-system)))
+ '((substitute* "configure"
+ (("\\$emul") "elf32ltsmipn32")))
+ '()))
%standard-phases)
;; XXX: The 'testsudoers' test series expects user 'root' to exist, but