aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/admin.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-08 11:26:46 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-10 09:28:48 +0100
commitd02f2cc48c8d74c0350f7a5508766fed2391105c (patch)
tree2c9d9eb3faec70a4345b31d821ba18e6ccee7a26 /gnu/packages/admin.scm
parentc9815b5deb66337756e1b7dacb3e9ca97d182cda (diff)
downloadguix-d02f2cc48c8d74c0350f7a5508766fed2391105c.tar.gz
guix-d02f2cc48c8d74c0350f7a5508766fed2391105c.zip
gnu: Add smartmontools.
* gnu/packages/admin.scm (smartmontools): New variable.
Diffstat (limited to 'gnu/packages/admin.scm')
-rw-r--r--gnu/packages/admin.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9aac9095e7..6244a87f94 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1028,3 +1028,27 @@ included utilities are designed to let admins and developers spot apps from
various ways that may be running with too much privilege.")
;; The library is lgpl2.1+, but also ships some utils which are gpl2+.
(license (list lgpl2.1+ gpl2+))))
+
+(define-public smartmontools
+ (package
+ (name "smartmontools")
+ (version "6.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/smartmontools/smartmontools/"
+ version "/smartmontools-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06gy71jh2d3gcfmlbbrsqw7215knkfq59q3j6qdxfrar39fhcxx7"))))
+ (build-system gnu-build-system)
+ (inputs `(("libcap-ng" ,libcap-ng)))
+ (home-page "http://www.smartmontools.org/")
+ (synopsis "S.M.A.R.T. harddisk control and monitoring tools")
+ (description
+ "The smartmontools package contains utility programs to control and
+monitor storage systems using the Self-Monitoring, Analysis and Reporting
+Technology System (S.M.A.R.T.) built into most modern ATA and SCSI harddisks.
+In many cases, these utilities will provide advanced warning of disk
+degradation and failure.")
+ (license gpl2+)))