aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/accessibility.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-01 22:21:09 +0200
commit8de4131b2ddd11faa3394cf497484563068c9e7a (patch)
treeed4ed9e586c7236f09c109afdd416dac18ba8cc3 /gnu/packages/accessibility.scm
parent15406013fe63f2ab238eec2d7a8adbc586806ac8 (diff)
parent45b7a8bfda5bde2e2daee4bec0ca092cd719d726 (diff)
downloadguix-8de4131b2ddd11faa3394cf497484563068c9e7a.tar.gz
guix-8de4131b2ddd11faa3394cf497484563068c9e7a.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/accessibility.scm')
-rw-r--r--gnu/packages/accessibility.scm94
1 files changed, 42 insertions, 52 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 0b06a189ea..e0a362ae4a 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -93,66 +93,56 @@ terminals.")
(define-public brltty
(package
(name "brltty")
- (version "6.5")
+ (version "6.6")
(source
(origin
(method url-fetch)
(uri
(string-append "https://brltty.app/archive/brltty-" version ".tar.gz"))
(sha256
- (base32 "1h62xzd5k0aaq2k4v3w93rizxnb8psvkxrlx62wr08ybwpspgp7z"))))
+ (base32 "1z54rin4zhg3294pq47gamzjy2c56zfkl07rx2qy2khlpyczds0k"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:tests? #f ; No target
-
- ;; High parallelism may cause errors such as:
- ;; ranlib: ./libbrlapi_stubs.a: error reading brlapi_stubs.o: file truncated
- #:parallel-build? #f
-
- #:configure-flags
- (list
- (string-append "--with-libbraille="
- (assoc-ref %build-inputs "libbraille"))
- (string-append "--with-espeak_ng="
- (assoc-ref %build-inputs "espeak-ng"))
- (string-append "--with-espeak="
- (assoc-ref %build-inputs "espeak"))
- (string-append "--with-flite="
- (assoc-ref %build-inputs "flite"))
- ;; Required for RUNPATH validation.
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out")
- "/lib"))
- #:make-flags
- (list
- (string-append "JAVA_JAR_DIR="
- (assoc-ref %outputs "out"))
- (string-append "JAVA_JNI_DIR="
- (assoc-ref %outputs "out"))
- (string-append "OCAML_DESTDIR="
- (assoc-ref %outputs "out")
- "/lib")
- (string-append "PYTHON_PREFIX="
- (assoc-ref %outputs "out"))
- "PYTHON_ROOT=/"
- (string-append "TCL_DIR="
- (assoc-ref %outputs "out")
- "/lib")
- "INSTALL_WRITABLE_DIRECTORY=no-thanks")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-errors
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "configure"
- (("/sbin/ldconfig")
- (which "true")))
- ;; Make Python bindings use rpath.
- (substitute* "Bindings/Python/setup.py.in"
- (("extra_compile_args =")
- (string-append "extra_link_args = ['-Wl,-rpath="
- (assoc-ref outputs "out")
- "/lib'], "
- "extra_compile_args = "))))))))
+ (list
+ #:tests? #f ; no target
+ ;; High parallelism may cause errors such as:
+ ;; ranlib: ./libbrlapi_stubs.a: error reading brlapi_stubs.o: file truncated
+ #:parallel-build? #f
+ #:configure-flags
+ #~(list
+ (string-append "--with-libbraille="
+ #$(this-package-input "libbraille"))
+ (string-append "--with-espeak_ng="
+ #$(this-package-input "espeak-ng"))
+ (string-append "--with-espeak="
+ #$(this-package-input "espeak"))
+ (string-append "--with-flite="
+ #$(this-package-input "flite"))
+ ;; Required for RUNPATH validation.
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
+ #:make-flags
+ #~(list
+ (string-append "JAVA_JAR_DIR=" #$output)
+ (string-append "JAVA_JNI_DIR=" #$output)
+ (string-append "OCAML_DESTDIR=" #$output "/lib")
+ (string-append "PYTHON_PREFIX=" #$output)
+ "PYTHON_ROOT=/"
+ (string-append "TCL_DIR=" #$output "/lib")
+ "INSTALL_WRITABLE_DIRECTORY=no-thanks")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-errors
+ (lambda _
+ (substitute* "configure"
+ (("/sbin/ldconfig")
+ (which "true")))
+ ;; Make Python bindings use rpath.
+ (substitute* "Bindings/Python/setup.py.in"
+ (("extra_compile_args =")
+ (string-append "extra_link_args = ['-Wl,-rpath="
+ #$output
+ "/lib'], "
+ "extra_compile_args = "))))))))
(native-inputs
(list clisp
python-cython