aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-09-26 21:39:17 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-09-26 21:47:38 +0300
commit3876ed32f25e160c47ba046d987ad9097b2bf0cb (patch)
tree29bf17bf7de7665d5e2357169f3348d953393e1a /gnu/installer
parent0939462e3f81bc98b38bdb7610e6a80ca1cbaa1b (diff)
downloadguix-3876ed32f25e160c47ba046d987ad9097b2bf0cb.tar.gz
guix-3876ed32f25e160c47ba046d987ad9097b2bf0cb.zip
gnu: Add webssh.
* gnu/packages/ssh.scm (webssh): New variable.
Diffstat (limited to 'gnu/installer')
0 files changed, 0 insertions, 0 deletions
%;'/>
1 files changed, 54 insertions, 0 deletions
diff --git a/test/compress/conditionals.js b/test/compress/conditionals.js
index 2212f85f..9af1630a 100644
--- a/test/compress/conditionals.js
+++ b/test/compress/conditionals.js
@@ -312,3 +312,57 @@ cond_7_1: {
x = (y, 2);
}
}
+
+cond_8: {
+ options = {
+ conditionals: true,
+ evaluate : true
+ };
+ input: {
+ // compress these
+ a = condition ? true : false;
+
+ a = !condition ? true : false;
+
+ a = condition() ? true : false;
+
+ if (condition) {
+ a = true;
+ } else {
+ a = false;
+ }
+
+ a = condition ? false : true;
+
+ a = !condition ? false : true;
+
+ a = condition() ? false : true;
+
+ if (condition) {
+ a = false;
+ } else {
+ a = true;
+ }
+
+ // don't compress these
+ a = condition ? 1 : false;
+
+ a = !condition ? true : 0;
+
+ a = condition ? 1 : 0;
+
+ }
+ expect: {
+ a = !!condition;
+ a = !condition;
+ a = !!condition();
+ a = !!condition;
+ a = !condition;
+ a = !!condition;
+ a = !condition();
+ a = !condition;
+ a = condition ? 1 : false;
+ a = condition ? 0 : true;
+ a = condition ? 1 : 0;
+ }
+} \ No newline at end of file