aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer/tests.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:24:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:27:28 -0400
commit3c6e220d8100281074c414a43c1efe9a01b53771 (patch)
treedc5d47fbbac3842d0da893adcd398dea10c1e681 /gnu/installer/tests.scm
parent08473753a0ebafef22c0894d846e3b42fd6be2a2 (diff)
parent62048ff9fcfbe3fc790a7207fc5f6f3e0476a02a (diff)
downloadguix-3c6e220d8100281074c414a43c1efe9a01b53771.tar.gz
guix-3c6e220d8100281074c414a43c1efe9a01b53771.zip
Merge branch 'master' into staging.
With resolved conflicts in: gnu/local.mk gnu/packages/crates-io.scm
Diffstat (limited to 'gnu/installer/tests.scm')
-rw-r--r--gnu/installer/tests.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/installer/tests.scm b/gnu/installer/tests.scm
index 3c049a1c85..8785cd9a9f 100644
--- a/gnu/installer/tests.scm
+++ b/gnu/installer/tests.scm
@@ -280,6 +280,10 @@ instrumented for further testing."
exp)))
(let ((content (call-with-input-file file read-expressions)))
+ ;; XXX: Remove the file before re-writing it, to be sure there are no
+ ;; leftovers. We shouldn't have to do that as CALL-WITH-OUTPUT-FILE uses
+ ;; the O_TRUNC flag by default.
+ (delete-file file)
(call-with-output-file file
(lambda (port)
(format port "\