aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer/newt
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:24:37 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 14:27:28 -0400
commit3c6e220d8100281074c414a43c1efe9a01b53771 (patch)
treedc5d47fbbac3842d0da893adcd398dea10c1e681 /gnu/installer/newt
parent08473753a0ebafef22c0894d846e3b42fd6be2a2 (diff)
parent62048ff9fcfbe3fc790a7207fc5f6f3e0476a02a (diff)
downloadguix-3c6e220d8100281074c414a43c1efe9a01b53771.tar.gz
guix-3c6e220d8100281074c414a43c1efe9a01b53771.zip
Merge branch 'master' into staging.
With resolved conflicts in: gnu/local.mk gnu/packages/crates-io.scm
Diffstat (limited to 'gnu/installer/newt')
-rw-r--r--gnu/installer/newt/partition.scm8
-rw-r--r--gnu/installer/newt/services.scm6
2 files changed, 6 insertions, 8 deletions
diff --git a/gnu/installer/newt/partition.scm b/gnu/installer/newt/partition.scm
index e7a97810ac..2adb4922b4 100644
--- a/gnu/installer/newt/partition.scm
+++ b/gnu/installer/newt/partition.scm
@@ -188,7 +188,7 @@ encryption of partition ~a (label: ~a).") file-name crypt-label)
(if (string=? password confirmation)
(user-partition
(inherit user-part)
- (crypt-password password))
+ (crypt-password (make-secret password)))
(begin
(run-error-page
(G_ "Password mismatch, please try again.")
@@ -795,13 +795,13 @@ by pressing the Exit button.~%~%")))
(user-partitions (run-page eligible-devices))
(user-partitions-with-pass (prompt-luks-passwords
user-partitions))
- (form (draw-formatting-page user-partitions)))
+ (form (draw-formatting-page user-partitions-with-pass)))
;; Make sure the disks are not in use before proceeding to formatting.
(free-parted eligible-devices)
(format-user-partitions user-partitions-with-pass)
(installer-log-line "formatted ~a user partitions"
(length user-partitions-with-pass))
- (installer-log-line "user-partitions: ~a" user-partitions)
+ (installer-log-line "user-partitions: ~a" user-partitions-with-pass)
(destroy-form-and-pop form)
- user-partitions))
+ user-partitions-with-pass))
diff --git a/gnu/installer/newt/services.scm b/gnu/installer/newt/services.scm
index 9951ad2212..b22024602c 100644
--- a/gnu/installer/newt/services.scm
+++ b/gnu/installer/newt/services.scm
@@ -99,10 +99,8 @@ non-graphical system.")
#:item->text (compose G_ system-service-name)
#:checkbox-tree-height 5
#:exit-button-callback-procedure
- (lambda ()
- (raise
- (condition
- (&installer-step-abort)))))))
+ (lambda _
+ (abort-to-prompt 'installer-step 'abort)))))
(define (run-network-management-page)
"Run a page to select among several network management methods."