aboutsummaryrefslogtreecommitdiff
path: root/gnu/installer/newt
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-24 20:03:57 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-25 00:45:35 +0200
commit399c31d40a918343c5513c3c4a0351f60ec5797b (patch)
tree112c0b8b5e3aa86c1b4dd072a371c94acc4bc59c /gnu/installer/newt
parent898677ed17672130d20434cd88575d620c97c553 (diff)
downloadguix-399c31d40a918343c5513c3c4a0351f60ec5797b.tar.gz
guix-399c31d40a918343c5513c3c4a0351f60ec5797b.zip
installer: 'run-input-page' has a new #:input-flags parameter.
* gnu/installer/newt/page.scm (run-input-page): Add #:input-flags and honor it.
Diffstat (limited to 'gnu/installer/newt')
-rw-r--r--gnu/installer/newt/page.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/installer/newt/page.scm b/gnu/installer/newt/page.scm
index 5c650652bd..e9514e110f 100644
--- a/gnu/installer/newt/page.scm
+++ b/gnu/installer/newt/page.scm
@@ -75,17 +75,20 @@ this page to TITLE."
#:key
(allow-empty-input? #f)
(default-text #f)
- (input-field-width 40))
+ (input-field-width 40)
+ (input-flags 0))
"Run a page to prompt user for an input. The given TEXT will be displayed
above the input field. The page title is set to TITLE. Unless
allow-empty-input? is set to #t, an error page will be displayed if the user
-enters an empty input."
+enters an empty input. INPUT-FLAGS is a bitwise-or'd set of flags for the
+input box, such as FLAG-PASSWORD."
(let* ((text-box
(make-reflowed-textbox -1 -1 text
input-field-width
#:flags FLAG-BORDER))
(grid (make-grid 1 3))
- (input-entry (make-entry -1 -1 20))
+ (input-entry (make-entry -1 -1 20
+ #:flags input-flags))
(ok-button (make-button -1 -1 (G_ "OK")))
(form (make-form)))
ct'>doc: Mention copyright/license auditing in `HACKING'.Ludovic Courtès 2013-06-09doc: Update bootstrap-related info in `HACKING'.Ludovic Courtès 2013-06-04doc: Write about patch submission and packaging guidelines.Ludovic Courtès * HACKING: Update the command names from `guix-build' to `guix build' & co. (Submitting Patches, Packaging Guidelines): New sections. * doc/guix.texi (Contributing): New section. 2013-02-12doc: Add the commit policy to HACKING.Ludovic Courtès * HACKING (Commit Access): New section. 2013-01-22doc: Add "The Perfect Setup" in 'HACKING'.Ludovic Courtès * HACKING (The Perfect Setup): New section. 2013-01-21Update 'HACKING'.Nikita Karetnikov * HACKING (When the platform is supported by Nixpkgs): Update the example. 2013-01-18Update `HACKING'.Ludovic Courtès * HACKING: Capitalize the title. (Running Guix before it is installed): New section. (Adding new packages): Update example. 2013-01-08doc: Update porting instructions in `HACKING'.Ludovic Courtès * HACKING (When the platform is supported by Nixpkgs): Update instructions. 2012-11-21doc: Document basic package definitions.Ludovic Courtès * doc/guix.texi (Programming Interface): Add introduction. (Defining Packages): Populate. 2012-11-18Turn Guix into "GNU Guix".Ludovic Courtès * configure.ac: Change package name to "GNU Guix", and bug-report address to `gnu-system-discuss@gnu.org'. * doc/guix.texi: Replace "Guix" by "GNU Guix" in some places. (Top, Introduction): Mention "for the GNU system". * HACKING, README: Use "GNU Guix" instead of "Guix" in some places. 2012-11-04distro: Move bootstrap packages to (distro packages bootstrap).Ludovic Courtès * distro/packages/base.scm (glibc-dynamic-linker, %bootstrap-guile, bootstrap-origin, package-from-tarball, %bootstrap-base-url, %bootstrap-coreutils&co, %bootstrap-binutils, %bootstrap-glibc, %bootstrap-gcc, %bootstrap-inputs, package-with-bootstrap-guile): Move to ... * distro/packages/bootstrap.scm: ... here. New file. * Makefile.am (MODULES): Add it. * tests/builders.scm: Use (distro packages bootstrap). (%bootstrap-guile): Remove. * tests/packages.scm: Likewise. * tests/union.scm: Likewise, and remove @@ to access %bootstrap-inputs. * tests/derivations.scm: Use (distro packages bootstrap) and remove @@ to access %bootstrap-coreutils&co. * HACKING (When the platform is supported by Nixpkgs): Update accordingly. 2012-11-04doc: Add "Adding new packages" in `HACKING'.Ludovic Courtès * HACKING (Adding new packages): New section. 2012-10-25doc: Add `HACKING'.Ludovic Courtès * HACKING: New file. * Makefile.am (EXTRA_DIST): Add it.