aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/activation.scm
diff options
context:
space:
mode:
authorNicolò Balzarotti <anothersms@gmail.com>2019-07-23 23:56:21 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-24 00:31:23 +0200
commit7304d5623ab5cc35289cb1535cbd0d8a37691fac (patch)
treeb3ef90844d82e9eff8e1bd9bb8b9b55fc3d665b0 /gnu/build/activation.scm
parent96a9a8d398b0bbb44ad96d41597a8f0323628e86 (diff)
downloadguix-7304d5623ab5cc35289cb1535cbd0d8a37691fac.tar.gz
guix-7304d5623ab5cc35289cb1535cbd0d8a37691fac.zip
gnu: julia: Update to 1.1.1.
* gnu/packages/julia.scm (libuv-julia): Update to commit 26dbe56. (libunwind-for-julia): Remove. (llvm-patch-url, llvm-patch): New procedures. (llvm-julia): New variable. (julia): Update to 1.1.1. [arguments]: Adjust 'prepare-deps' to new set of dependencies. Adjust 'hardcode-soname-map': remove openlibm and libfftw handling. Update file names in 'fix-include-and-link-paths' and 'hardcode-paths'. Adjust 'disable-broken-tests'. Pass PREFIX, LIBFLAS, and LIBBLASNAME in #:make-flags; update other flags. [inputs]: Replace LLVM-3.9.1 with LLVM-JULIA. Replace LIBUNWIND-FOR-JULIA with LIBUNWIND. Add "rmath" and "libwhich". [native-inputs]: Remove "unicode-data". Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/build/activation.scm')
0 files changed, 0 insertions, 0 deletions
>- if (!node) return false;
- }
+ if (node instanceof AST_Assign) return node.operator == "=" && is_object(node.right);
+ if (node instanceof AST_Sequence) return is_object(node.tail_node());
+ if (node instanceof AST_SymbolRef) return is_object(node.fixed_value());
return node instanceof AST_Array
|| node instanceof AST_Lambda
|| node instanceof AST_New
@@ -7758,14 +7762,16 @@ merge(Compressor.prototype, {
associative = compressor.option("unsafe_math");
// +a - b => a - b
// a - +b => a - b
- if (self.operator != "+") {
- if (self.left instanceof AST_UnaryPrefix && self.left.operator == "+") {
- self.left = self.left.expression;
- }
- if (self.right instanceof AST_UnaryPrefix && self.right.operator == "+") {
- self.right = self.right.expression;
+ [ "left", "right" ].forEach(function(operand) {
+ var node = self[operand];
+ if (node instanceof AST_UnaryPrefix && node.operator == "+") {
+ var exp = node.expression;
+ if (exp.is_boolean(compressor) || exp.is_number(compressor)
+ || self.operator != "+" && exp.is_string(compressor)) {
+ self[operand] = exp;
+ }
}
- }
+ });
case "&":
case "|":
case "^":