aboutsummaryrefslogtreecommitdiff
path: root/etc/manifests/ungraft.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-02 16:20:04 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-12 23:23:34 +0100
commit5e2daf4b10cdbb7b5b3a7b1a49b0dfdba4346748 (patch)
treea7fdcef82ec471287f32e92ad4f03badecf25304 /etc/manifests/ungraft.scm
parent46a8922105a8162a7ecabfb66b4242e072e22ef3 (diff)
downloadguix-5e2daf4b10cdbb7b5b3a7b1a49b0dfdba4346748.tar.gz
guix-5e2daf4b10cdbb7b5b3a7b1a49b0dfdba4346748.zip
maint: Add ungrafting manifest.
* etc/manifests/ungraft.scm: New file. * Makefile.am (EXTRA_DIST): Add it. Change-Id: If4aa7649721b93d3297ecd967d5db4a6b71ec6eb
Diffstat (limited to 'etc/manifests/ungraft.scm')
-rw-r--r--etc/manifests/ungraft.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/etc/manifests/ungraft.scm b/etc/manifests/ungraft.scm
new file mode 100644
index 0000000000..3e42b98ece
--- /dev/null
+++ b/etc/manifests/ungraft.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;; This manifest "ungrafts" all the currently grafted packages and returns
+;; said packages and all their dependents.
+
+(use-modules (guix diagnostics)
+ (guix i18n)
+ (guix packages)
+ (guix profiles)
+ (guix store)
+ ((guix scripts build) #:select (dependents))
+ ((gnu packages) #:select (all-packages))
+ (srfi srfi-1))
+
+(define (grafted-packages)
+ (info (G_ "enumerating grafted packages...~%"))
+ (let ((result (filter package-replacement (all-packages))))
+ (info (G_ "found ~d grafted packages:~{ ~a~}~%")
+ (length result) (map package-full-name result))
+ result))
+
+(manifest
+ (with-store store
+ (let* ((grafted (grafted-packages))
+ (ungraft-all (package-input-rewriting
+ (map (lambda (package)
+ `(,package . ,(package-replacement package)))
+ grafted))))
+ (map (lambda (package)
+ (manifest-entry
+ (inherit (package->manifest-entry (ungraft-all package)))
+ (name (string-append (package-name package) "-ungrafted"))))
+ (dependents store grafted)))))