aboutsummaryrefslogtreecommitdiff
path: root/etc/manifests/kernels.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-12-02 15:04:46 +0100
committerLudovic Courtès <ludo@gnu.org>2024-12-12 23:23:33 +0100
commit12d00767f036029f1f5738de644d4972db374f4f (patch)
tree5ea390393940fde1ad29fadfb0f13a72bf32a042 /etc/manifests/kernels.scm
parentb8a45bd0473ab2ba9b96b7ef429a557ece9bf06c (diff)
downloadguix-12d00767f036029f1f5738de644d4972db374f4f.tar.gz
guix-12d00767f036029f1f5738de644d4972db374f4f.zip
etc: Move manifests to a separate directory.
* etc/disarchive-manifest.scm, etc/hurd-manifest.scm, etc/kernels-manifest.scm, etc/release-manifest.scm, etc/source-manifest.scm, etc/system-tests.scm, etc/time-travel-manifest.scm, etc/upgrade-manifest.scm: Move to… * etc/manifests: … here, and drop “-manifest” from file name. * Makefile.am (EXTRA_DIST, assert-binaries-available, check-system): Adjust accordingly. Change-Id: Iedee3d0cdd42e72ef8bbf654ea5d3b47dca95874
Diffstat (limited to 'etc/manifests/kernels.scm')
-rw-r--r--etc/manifests/kernels.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/etc/manifests/kernels.scm b/etc/manifests/kernels.scm
new file mode 100644
index 0000000000..bacb222d64
--- /dev/null
+++ b/etc/manifests/kernels.scm
@@ -0,0 +1,35 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Leo Famulari <leo@famulari.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;; This file returns a manifest of packages related to linux-libre.
+;;; Simplistically, it selects packages whose names begin with "linux-libre".
+;;; It is used to assist continuous integration of the kernel packages.
+
+(use-modules (guix packages)
+ (guix profiles)
+ (gnu packages))
+
+(manifest
+ (map package->manifest-entry
+ (fold-packages
+ (lambda (package lst)
+ (if (string-prefix? "linux-libre"
+ (package-name package))
+ (cons package lst)
+ lst))
+ '())))