path: root/emacs.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-01 10:13:13 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-01 13:59:58 +0200
commit915363a3e2ebd264c329756661779a22247bcc42 (patch)
treed4585db6ac3b8458be801437dcd6b2507de4889c /emacs.am
parentf5480572d0e1c8dffce72a6e393cae937d6b2d3d (diff)
downloadguix-915363a3e2ebd264c329756661779a22247bcc42.tar.gz
guix-915363a3e2ebd264c329756661779a22247bcc42.zip
gnu: wicd: Add template for WPA2-TTLS.
* gnu/packages/patches/wicd-wpa2-ttls.patch: New file. * gnu/packages/wicd.scm (wicd)[source]: Add it. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'emacs.am')
0 files changed, 0 insertions, 0 deletions
load.scm
@@ -383,6 +383,10 @@ connections allowed to MACHINE."
"Release SLOT, a build slot as returned as by 'acquire-build-slot'."
(close-port slot))
+(define %slots
+ ;; List of acquired build slots (open ports).
+ '())
+
(define (choose-build-machine requirements machines)
"Return the best machine among MACHINES fulfilling REQUIREMENTS, or #f."
@@ -418,7 +422,10 @@ connections allowed to MACHINE."
;; Return the best machine unless it's already overloaded.
(if (< (machine-load best) 2.)
- best
+ (begin
+ ;; Prevent SLOT from being GC'd.
+ (set! %slots (cons slot %slots))
+ best)
(begin
(release-build-slot slot)
#f)))