aboutsummaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2023-06-21 08:06:13 -0700
committerLudovic Courtès <ludo@gnu.org>2023-10-21 00:27:25 +0200
commite011961f99e3cab8ff1972de2b4659e972bb00a0 (patch)
treefd899cdb79327cc7216a56a4392116b7c6eb446d /doc
parent37792ee3529a78d1f2c6378533e45642ce36b649 (diff)
downloadguix-e011961f99e3cab8ff1972de2b4659e972bb00a0.tar.gz
guix-e011961f99e3cab8ff1972de2b4659e972bb00a0.zip
build-system: Add zig-build-system.
* guix/build-system/zig.scm: New file. * guix/build/zig-build-system.scm: New file. * Makefile.am: Add them. * doc/guix.texi: Document it. * etc/snippets/yas/scheme-mode/guix-package (build-system): Add zig-build-system. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'doc')
-rw-r--r--doc/guix.texi21
1 files changed, 21 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 91408b8e62..60d3ab3336 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -10219,6 +10219,27 @@ Python package is used to run the script can be specified with the
@code{#:python} parameter.
@end defvar
+@defvar zig-build-system
+This variable is exported by @code{(guix build-system zig)}. It implements
+the build procedures for the @uref{https://ziglang.org/, Zig}
+build system (@command{zig build} command).
+
+Selecting this build system adds @code{zig} to the package inputs, in
+addition to the packages of @code{gnu-build-system}.
+
+There is no @code{configure} phase because Zig packages typically do not
+need to be configured. The @code{#:zig-build-flags} parameter is a list of
+flags that are passed to the @code{zig} command during the build. The
+@code{#:zig-test-flags} parameter is a list of flags that are passed to the
+@code{zig test} command during the @code{check} phase. The default compiler
+package can be overridden with the @code{#:zig} argument.
+
+The optional @code{zig-release-type} parameter declares the type of release.
+Possible values are: @code{safe}, @code{fast}, or @code{small}. The default
+value is @code{#f}, which causes the release flag to be omitted from the
+@code{zig} command. That results in a @code{debug} build.
+@end defvar
+
@defvar scons-build-system
This variable is exported by @code{(guix build-system scons)}. It
implements the build procedure used by the SCons software construction