aboutsummaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-25 15:14:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:55 +0000
commit37ef7683de5f3f93c1dbbb15f78e02d4c6831089 (patch)
tree57a208ee442a0b5c39c6c1f267863d2a3014eddd /doc
parent0a2817cb052880b854242f0c5cc055e16036d80e (diff)
downloadguix-37ef7683de5f3f93c1dbbb15f78e02d4c6831089.tar.gz
guix-37ef7683de5f3f93c1dbbb15f78e02d4c6831089.zip
gnu: go-github-com-dustin-go-humanize: Update to 1.0.1.
* gnu/packages/golang.scm (go-github-com-dustin-go-humanize): Update to 1.0.1. Change-Id: Iaeb4c79c802794feb03e307c08fa56686294942a
Diffstat (limited to 'doc')
0 files changed, 0 insertions, 0 deletions
td> -rw-r--r--gnu/packages/base.scm1
-rw-r--r--gnu/packages/patches/glibc-2.38-hurd-ucontext.patch87
3 files changed, 89 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 597f346901..31a4524fd1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1397,6 +1397,7 @@ dist_patch_DATA = \
%D%/packages/patches/glibc-2.37-hurd-clock_t_centiseconds.patch \
%D%/packages/patches/glibc-2.37-hurd-local-clock_gettime_MONOTONIC.patch \
%D%/packages/patches/glibc-2.37-versioned-locpath.patch \
+ %D%/packages/patches/glibc-2.38-hurd-ucontext.patch \
%D%/packages/patches/glibc-2.38-ldd-x86_64.patch \
%D%/packages/patches/glibc-hurd-clock_t_centiseconds.patch \
%D%/packages/patches/glibc-hurd-getauxval.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 098a6070dd..af81169850 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -863,6 +863,7 @@ the store.")
"glibc-supported-locales.patch"
"glibc-2.37-hurd-clock_t_centiseconds.patch"
"glibc-2.37-hurd-local-clock_gettime_MONOTONIC.patch"
+ "glibc-2.38-hurd-ucontext.patch"
"glibc-hurd-mach-print.patch"
"glibc-hurd-gettyent.patch"
"glibc-hurd-getauxval.patch"))))
diff --git a/gnu/packages/patches/glibc-2.38-hurd-ucontext.patch b/gnu/packages/patches/glibc-2.38-hurd-ucontext.patch
new file mode 100644
index 0000000000..03a6132666
--- /dev/null
+++ b/gnu/packages/patches/glibc-2.38-hurd-ucontext.patch
@@ -0,0 +1,87 @@
+commit 29d4591b07a4da53320e949557c6946c62c26bde
+Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
+Date: Thu Sep 28 00:07:18 2023 +0200
+
+ hurd: Drop REG_GSFS and REG_ESDS from x86_64's ucontext
+
+ These are useless on x86_64, and __NGREG was actually wrong with them.
+
+diff --git a/sysdeps/mach/hurd/x86/trampoline.c b/sysdeps/mach/hurd/x86/trampoline.c
+index 6318c9528a..bc3f15e1e0 100644
+--- a/sysdeps/mach/hurd/x86/trampoline.c
++++ b/sysdeps/mach/hurd/x86/trampoline.c
+@@ -79,8 +79,8 @@ static void fill_ucontext (ucontext_t *uc, const struct sigcontext *sc)
+
+ /* Registers. */
+ #ifdef __x86_64__
+- memcpy (&uc->uc_mcontext.gregs[REG_GSFS], &sc->sc_gs,
+- (REG_ERR - REG_GSFS) * sizeof (long));
++ memcpy (&uc->uc_mcontext.gregs[REG_R8], &sc->sc_r8,
++ (REG_ERR - REG_R8) * sizeof (long));
+ #else
+ memcpy (&uc->uc_mcontext.gregs[REG_GS], &sc->sc_gs,
+ (REG_TRAPNO - REG_GS) * sizeof (int));
+diff --git a/sysdeps/mach/hurd/x86_64/bits/sigcontext.h b/sysdeps/mach/hurd/x86_64/bits/sigcontext.h
+index 6396054463..7facc587b8 100644
+--- a/sysdeps/mach/hurd/x86_64/bits/sigcontext.h
++++ b/sysdeps/mach/hurd/x86_64/bits/sigcontext.h
+@@ -59,13 +59,7 @@ struct sigcontext
+ }
+ trampoline.c knows this, so it must be changed if this changes. */
+
+-#define sc_i386_thread_state sc_gs /* Beginning of correspondence. */
+- /* Segment registers. */
+- int sc_gs;
+- int sc_fs;
+- int sc_es;
+- int sc_ds;
+-
++#define sc_i386_thread_state sc_r8 /* Beginning of correspondence. */
+ long sc_r8;
+ long sc_r9;
+ long sc_r10;
+diff --git a/sysdeps/mach/x86/thread_state.h b/sysdeps/mach/x86/thread_state.h
+index 8c419515f9..e237e46cb2 100644
+--- a/sysdeps/mach/x86/thread_state.h
++++ b/sysdeps/mach/x86/thread_state.h
+@@ -34,12 +34,13 @@
+ #define PC rip
+ #define SP ursp
+ #define SYSRETURN rax
++#define MACHINE_THREAD_STATE_FIX_NEW(ts) do { \
++ asm ("mov %%cs, %w0" : "=q" ((ts)->cs)); \
++} while(0)
+ #else
+ #define PC eip
+ #define SP uesp
+ #define SYSRETURN eax
+-#endif
+-
+ #define MACHINE_THREAD_STATE_FIX_NEW(ts) do { \
+ asm ("mov %%cs, %w0" : "=q" ((ts)->cs)); \
+ asm ("mov %%ds, %w0" : "=q" ((ts)->ds)); \
+@@ -47,6 +48,7 @@
+ asm ("mov %%fs, %w0" : "=q" ((ts)->fs)); \
+ asm ("mov %%gs, %w0" : "=q" ((ts)->gs)); \
+ } while(0)
++#endif
+
+ struct machine_thread_all_state
+ {
+diff --git a/sysdeps/x86_64/sys/ucontext.h b/sysdeps/x86_64/sys/ucontext.h
+index d73a893795..f1b6be77a7 100644
+--- a/sysdeps/x86_64/sys/ucontext.h
++++ b/sysdeps/x86_64/sys/ucontext.h
+@@ -47,11 +47,7 @@ typedef greg_t gregset_t[__NGREG];
+ /* Number of each register in the `gregset_t' array. */
+ enum
+ {
+- REG_GSFS = 0, /* Actually int gs, fs. */
+-# define REG_GSFS REG_GSFS
+- REG_ESDS, /* Actually int es, ds. */
+-# define REG_ESDS REG_ESDS
+- REG_R8,
++ REG_R8 = 0,
+ # define REG_R8 REG_R8
+ REG_R9,
+ # define REG_R9 REG_R9