about
aboutsummaryrefslogtreecommitdiff
path: root/doc/images/shepherd-graph.dot
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-23 09:36:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-23 09:36:35 +0200
commitcde7068e8cb28b7245cfa07b8aa788039012f972 (patch)
treee5f2bba3243d21e6ce77a5705aa77fc60372f8d0 /doc/images/shepherd-graph.dot
parent6b83da96162fe212a4e306b259c2c52f17878ec5 (diff)
downloadguix-cde7068e8cb28b7245cfa07b8aa788039012f972.tar.gz
guix-cde7068e8cb28b7245cfa07b8aa788039012f972.zip
gnu: texmacs: Update to 2.1.
* gnu/packages/text-editors.scm (texmacs): Update to 2.1. [arguments]: Remove #t at the end of phases.
Diffstat (limited to 'doc/images/shepherd-graph.dot')
0 files changed, 0 insertions, 0 deletions
;; If FILE is a symlink to an absolute file name,
+ ;; resolve it as if we were under /root.
+ (let ((st (lstat file)))
+ (if (eq? 'symlink (stat:type st))
+ (let ((target (readlink file)))
+ (resolve (string-append "/root" target)))
+ file)))))
(format #t "loading boot file '~a'...\n" to-load)
- (compile-file (string-append "/root/" to-load)
+ (compile-file (resolve (string-append "/root/" to-load))
#:output-file "/root/loader.go"
#:opts %auto-compilation-options)
(match (primitive-fork)
@@ -392,7 +400,7 @@ the Linux kernel.")
(sleep 2)
(reboot))
(begin
- (display "no init file passed via '--exec'\n")
+ (display "no init file passed via '--load'\n")
(display "entering a warm and cozy REPL\n")
((@ (system repl repl) start-repl))))))
#:name "qemu-system-initrd"