aboutsummaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:00:31 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:22 +0100
commitd7ad08239be312e48c18487bf4b6cc173970de6d (patch)
treecffdc05f26419f446bf298b9371821556351f4dc /build-aux
parent503447ad4e06fbd64374563abbae2328568c3eda (diff)
downloadguix-d7ad08239be312e48c18487bf4b6cc173970de6d.tar.gz
guix-d7ad08239be312e48c18487bf4b6cc173970de6d.zip
gnu: Add ghc-utf8-light.
* gnu/packages/haskell-xyz.scm (ghc-utf8-light): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'build-aux')
0 files changed, 0 insertions, 0 deletions
m
index aa74063ace..4b23dac960 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19337,6 +19337,26 @@ multitouch applications.")
(description "This package provides a MediaWiki API client.")
(license license:expat)))
+(define-public python-kneed
+ (package
+ (name "python-kneed")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "kneed" version))
+ (sha256
+ (base32 "0vkwi0pr7nfkp3c46hnmx0275yx68v96v10rmspv0wis33x6f39l"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-matplotlib python-numpy python-scipy))
+ (home-page "https://github.com/arvkevi/kneed")
+ (synopsis "Knee-point detection in Python")
+ (description "This package implements the kneedle algorithm. Given a set
+of x and y values, kneed will return the knee point of the function. The knee
+point is the point of maximum curvature.")
+ (license license:bsd-3)))
+
(define-public python-utils
(package
(name "python-utils")