aboutsummaryrefslogtreecommitdiff
path: root/COPYING
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-01-25 17:38:53 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-21 14:56:31 +0100
commit62489932a01d6b0c43759b64b08b8aea25331dad (patch)
treead54a1035e11d757a7f3abfdd8c7455c17187e53 /COPYING
parent27e982e0d338531cadc79a783d84c7e837f277a2 (diff)
downloadguix-62489932a01d6b0c43759b64b08b8aea25331dad.tar.gz
guix-62489932a01d6b0c43759b64b08b8aea25331dad.zip
gnu: xf86-video-qxl: Change to libxfont2 ABI.
* gnu/packages/xorg.scm (xf86-video-qxl)[inputs]: Change LIBXFONT to LIBXFONT2.
Diffstat (limited to 'COPYING')
0 files changed, 0 insertions, 0 deletions
packages/python.scm b/gnu/packages/python.scm
index 5234dba2d2..28b38cfae6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6664,6 +6664,35 @@ Debian-related files, such as:
(define-public python2-debian
(package-with-python2 python-debian))
+(define-public python-nbformat
+ (package
+ (name "python-nbformat")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "nbformat" version))
+ (sha256
+ (base32
+ "0mq8iki3d4mnx7wy05phss7x98mds4fqydin8lcagidp1knw1xnv"))))
+ (build-system python-build-system)
+ (arguments `(#:tests? #f)) ; no test target
+ (propagated-inputs
+ `(("python-ipython-genutils" ,python-ipython-genutils)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-jupyter-core" ,python-jupyter-core)
+ ("python-traitlets" ,python-traitlets)))
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "http://jupyter.org")
+ (synopsis "Jupyter Notebook format")
+ (description "This package provides the reference implementation of the
+Jupyter Notebook format and Python APIs for working with notebooks.")
+ (license license:bsd-3)))
+
+(define-public python2-nbformat
+ (package-with-python2 python-nbformat))
+
(define-public python-chardet
(package
(name "python-chardet")