aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-01 00:11:25 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-01 00:11:25 +0100
commitff512401c30e7f1dbda39a49930274f83e2da411 (patch)
treef12582a5ed8aded625e53eaf6202edfe46356f5e
parentf9ac8b766658889a8291b2f5bb3bcde76218e238 (diff)
downloadguix-ff512401c30e7f1dbda39a49930274f83e2da411.tar.gz
guix-ff512401c30e7f1dbda39a49930274f83e2da411.zip
gnu: emacs-detached: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-detached)[arguments]<#:phases>: Remove unnecessary call to MAKE-FILE-WRITABLE. [synopsis]: Do not start with an article. [description]: Use proper capitalization.
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 17fc2dffee..141846f952 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26033,7 +26033,6 @@ according to their use.")
#~(modify-phases %standard-phases
(add-after 'unpack 'configure
(lambda* (#:key inputs #:allow-other-keys)
- (make-file-writable "detached.el")
(emacs-substitute-variables "detached.el"
("detached-dtach-program"
(search-input-file inputs "/bin/dtach"))
@@ -26043,11 +26042,11 @@ according to their use.")
(native-inputs (list emacs-ert-runner))
(inputs (list dtach))
(home-page "https://git.sr.ht/~niklaseklund/detached.el")
- (synopsis "A package to launch, and manage, detached processes")
+ (synopsis "Launch and manage detached processes from Emacs")
(description
- "The detached package allows users to run processes
-detached from Emacs. It provides integration with multiple built-in modes, as
-well as providing an interface to attach and interact with the processes.")
+ "The Detached package allows users to run processes detached from Emacs.
+It provides integration with multiple built-in modes, as well as providing an
+interface to attach and interact with the processes.")
(license license:gpl3+)))
(define-public emacs-dtache