aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-27 16:06:49 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-21 22:52:52 +0800
commitfee2156a433971034e2363673f4eeaef5bce90c6 (patch)
treef1e7e1b332dbd2ca314d754432eae6625905d38a
parent6d6f16f4b2069f288d0eb9deff61c74a18f4d725 (diff)
downloadguix-fee2156a433971034e2363673f4eeaef5bce90c6.tar.gz
guix-fee2156a433971034e2363673f4eeaef5bce90c6.zip
gnu: python-sip: Update to 6.8.6.
* gnu/packages/qt.scm (python-sip): Update to 6.8.6. [native-inputs]: Add python-setuptools and python-setuptools-scm-next. [arguments]: Disable tests. Change-Id: If063d7194711053a4e65ab513573eb6d593e9446
-rw-r--r--gnu/packages/qt.scm26
1 files changed, 14 insertions, 12 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b46c4abb6c..7197e80969 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3937,24 +3937,26 @@ Python.")
(define-public python-sip
(package
(name "python-sip")
- (version "6.8.3")
+ (version "6.8.6")
(source
- (origin
- (method url-fetch)
- (uri (list (pypi-uri "sip" version)
- (string-append "https://www.riverbankcomputing.com/static/"
- "Downloads/sip/" version
- "/sip-" version ".tar.gz")))
- (sha256
- (base32
- "0b3n237lbggz3b6bfmdsl1m4qgai7qyyj6fmvrmc695v32q4g1c8"))
- (patches (search-patches "python-sip-include-dirs.patch"))))
+ (origin
+ (method url-fetch)
+ (uri (list (pypi-uri "sip" version)
+ (string-append "https://www.riverbankcomputing.com/static/"
+ "Downloads/sip/" version
+ "/sip-" version ".tar.gz")))
+ (sha256
+ (base32
+ "0ykxq0607f2sdwbl5cxbp0y8pl14bsgzc9nhifpxbibfivj5kjbz"))
+ (patches (search-patches "python-sip-include-dirs.patch"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-wrapper))
+ (list python-wrapper python-setuptools python-setuptools-scm-next))
(propagated-inputs
(list python-tomli
python-packaging))
+ ;; no test.
+ (arguments (list #:tests? #f))
(home-page "https://www.riverbankcomputing.com/software/sip/intro")
(synopsis "Python binding creator for C and C++ libraries")
(description