aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 12:40:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:22 +0200
commitfe0ce730c6e517a114b1cd1fb0027b54cca2b12d (patch)
treea8d73d394cb1f21d179a19e54207204999802616
parent07092d64f1f4893d384fd39c49ba337a89a9f810 (diff)
downloadguix-fe0ce730c6e517a114b1cd1fb0027b54cca2b12d.tar.gz
guix-fe0ce730c6e517a114b1cd1fb0027b54cca2b12d.zip
gnu: texlive-threeparttablex: Refresh package definition.
* gnu/packages/tex.scm (texlive-threeparttablex): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-ENVIRON, TEXLIVE-THREEPARTTABLE.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 18 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 52b79094b8..e54a501635 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -12220,17 +12220,24 @@ provided by Philipp Lehmann’s etoolbox.")
(define-public texlive-threeparttablex
(package
- (inherit (simple-texlive-package
- "texlive-threeparttablex"
- (list "doc/latex/threeparttablex/"
- "tex/latex/threeparttablex/")
- (base32
- "19pvw2ifswxcf8dxw0mzjmqhl592477w5hcfh97f4wpya0dv2m9p")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/threeparttablex")
- (synopsis "Notes in longtables")
- (description "The package provides the functionality of the
-threeparttable package to tables created using the longtable package.")
+ (name "texlive-threeparttablex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/threeparttablex/"
+ "tex/latex/threeparttablex/")
+ (base32
+ "19pvw2ifswxcf8dxw0mzjmqhl592477w5hcfh97f4wpya0dv2m9p")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-environ
+ texlive-threeparttable))
+ (home-page "https://ctan.org/pkg/threeparttablex")
+ (synopsis "Notes in @code{longtables}")
+ (description
+ "The package provides the functionality of the @code{threeparttable}
+package to tables created using the @code{longtable} package.")
(license license:lppl1.3+)))
(define-public texlive-lineno