aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-12-19 22:04:23 +0100
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-20 10:32:36 +0100
commitfd86ec952dbecb9880e7a27b0501497e33e226b5 (patch)
tree3bbdbaf397974fadebce372735eb4079c420f4a7
parent5e82c33839b1c02a3db8ef22f7b52e10d97a2f78 (diff)
downloadguix-fd86ec952dbecb9880e7a27b0501497e33e226b5.tar.gz
guix-fd86ec952dbecb9880e7a27b0501497e33e226b5.zip
gnu: Add python-webcolors@24.11.1.
* gnu/packages/python-web.scm (python-webcolors-24): New variable. Change-Id: I3d4aa5e37d2518cc1b3d8c1f43e11b96c51f0ca9
-rw-r--r--gnu/packages/python-web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a14db7bd9f..abbe61b808 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -8771,6 +8771,38 @@ Only the RGB colorspace is supported. Conversion to/from the HSL colorspace
can be handled by the @code{colorsys} module in the Python standard library.")
(license license:bsd-3)))
+(define-public python-webcolors-24
+ (package
+ (inherit python-webcolors)
+ (name "python-webcolors")
+ (version "24.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "webcolors" version))
+ (sha256
+ (base32 "1xl0vn4xa03vjwx6fj19q9kgb94g65gvdf3p0ivsy0i2ydldgczc"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-error
+ (lambda _
+ ;; pdm wants optional-dependencies instead of dependency-groups.
+ ;; See <https://pdm-project.org/en/latest/usage/dependency/>.
+ (substitute* "pyproject.toml"
+ (("\\[dependency-groups\\]")
+ "[project.optional-dependencies]"))))
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ ;; Our python-nox version is incompatible,
+ ;; so use pytest instead.
+ (invoke "pytest")))))))
+ (native-inputs (list python-pdm-backend python-pytest))
+ (license license:bsd-3)))
+
(define-public python-woob
(package
(name "python-woob")