aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 19:39:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:33 +0200
commitfd198a23f358bf329c0fe1f9f3755a2bcc95c06b (patch)
tree9d47d7aa1f1f8cfb33821d72651aa2760f841f2b
parenta06ebba8168f1e85a973dcd5b6a1fefe4281cf46 (diff)
downloadguix-fd198a23f358bf329c0fe1f9f3755a2bcc95c06b.tar.gz
guix-fd198a23f358bf329c0fe1f9f3755a2bcc95c06b.zip
gnu: texlive-microtype: Refresh package definition.
* gnu/packages/tex.scm (texlive-microtype): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-GRAPHICS.
-rw-r--r--gnu/packages/tex.scm51
1 files changed, 28 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d6d541c507..0291109c7c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10898,29 +10898,34 @@ included in the @code{units} bundle.")
(license license:gpl3+))))
(define-public texlive-microtype
- (let ((template (simple-texlive-package
- "texlive-microtype"
- (list "/doc/latex/microtype/"
- "/tex/latex/microtype/")
- (base32
- "07861ixrjzxm0l24z82ivhaj4v6xm4ijbaabp66jxsf8s8h7dq9n")
- #:trivial? #t)))
- (package
- (inherit template)
- (home-page "http://www.ctan.org/pkg/microtype")
- (synopsis "Subliminal refinements towards typographical perfection")
- (description "@code{microtype} provides a LaTeX interface to the
-micro-typographic extensions that were introduced by pdfTeX and have
-since propagated to XeTeX and LuaTeX: most prominently character
-protrusion and font expansion, the adjustment of kerning and interword
-spacing, hyphenatable letterspacing and the possibility to disable all
-or selected ligatures. These features may be applied to customisable
-sets of fonts. All micro-typographic aspects of the fonts can be
-configured in a straight-forward and flexible way. Settings for
-various fonts are provided. An alternative package
-@code{letterspace}, which also works with plain TeX, is included in
-the bundle.")
- (license license:lppl1.3c))))
+ (package
+ (name "texlive-microtype")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/microtype/"
+ "source/latex/microtype/"
+ "tex/latex/microtype/")
+ (base32
+ "1r9w6za8g263n16pz0r5adrx5sazhfa78rdhjj9idnif12bgvpq2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-graphics))
+ (home-page "https://ctan.org/pkg/microtype")
+ (synopsis "Subliminal refinements towards typographical perfection")
+ (description
+ "The package provides a LaTeX interface to the micro-typographic
+extensions that were introduced by pdfTeX and have since also propagated to
+XeTeX and LuaTeX: most prominently, character protrusion and font expansion,
+furthermore the adjustment of interword spacing and additional kerning, as
+well as hyphenatable letterspacing (tracking) and the possibility to disable
+all or selected ligatures. These features may be applied to customisable sets
+of fonts, and all micro-typographic aspects of the fonts can be configured in
+a straight-forward and flexible way. An alternative package
+@code{letterspace}, which also works with plain TeX, is included in the
+bundle.")
+ (license license:lppl1.3c)))
(define-public texlive-minitoc
(package