aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2024-07-12 12:27:13 +0200
committerLudovic Courtès <ludo@gnu.org>2024-07-18 17:31:18 +0200
commitfcd3c5d3aa2894218f357d69f7a307ebc3b318bc (patch)
treefcca625ca52429ca15be1a35a8e377239e015a4c
parenta9d8ad6595b5501e3b257266370591759b5bd82e (diff)
downloadguix-fcd3c5d3aa2894218f357d69f7a307ebc3b318bc.tar.gz
guix-fcd3c5d3aa2894218f357d69f7a307ebc3b318bc.zip
gnu: hwloc: Update to 2.11.1.
* gnu/packages/mpi.scm (hwloc-2): Update to 2.11.1. [native-inputs]: Add BASH. Co-authored-by: Philippe SWARTVAGHER <phil.swart@gmx.fr> Change-Id: If5531cb82911833153b0e795e9f20b0d0ae940c2
-rw-r--r--gnu/packages/mpi.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 6270108b16..4c18da30ef 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -35,6 +35,7 @@
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages fabric-management)
#:use-module (gnu packages gcc)
@@ -143,7 +144,7 @@ bind processes, and much more.")
(define-public hwloc-2
(package
(inherit hwloc-1)
- (version "2.10.0")
+ (version "2.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -151,11 +152,12 @@ bind processes, and much more.")
"/hwloc-" version ".tar.bz2"))
(sha256
(base32
- "14hkmq2hrs4j5f0sf32aazgbhgbdvj7lwapy35jvwbyyr5hds183"))))
+ "1ikhg35pll9zs628n2nii3ranz9j850hykqqcrgy2p12mpzzpk84"))))
- ;; libnuma is no longer needed.
+ (native-inputs (modify-inputs (package-native-inputs hwloc-1)
+ (append bash))) ;for completion tests
(inputs (modify-inputs (package-inputs hwloc-1)
- (delete "numactl")))
+ (delete "numactl"))) ;libnuma is no longer needed.
(arguments
(substitute-keyword-arguments (package-arguments hwloc-1)
((#:phases phases)