aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:18 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:57 +0000
commitfc9ef6d61a8f0ba731c0db5db4027530a2fa243a (patch)
tree8254260ede1316c0b2e5cdc9586bcd5068490e30
parentb59a4226712a8facbaa13cdffa5a4479d366a860 (diff)
downloadguix-fc9ef6d61a8f0ba731c0db5db4027530a2fa243a.tar.gz
guix-fc9ef6d61a8f0ba731c0db5db4027530a2fa243a.zip
gnu: python-numpydoc: Move to pyproject-build-sytem.
* gnu/packages/python-xyz.scm (python-numpydoc): [build-system]: Move to pyproject-build-sytem. [arguments]: Move <#:phases> check replacement to <#:test-flags>. Change-Id: Ia7a812c4ee2adcd31fc32db1caa7c163cadf46bf Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aa4f69acdf..dcfbb5db53 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9469,16 +9469,12 @@ parse and apply unified diffs. It has features such as:
(sha256
(base32
"0k2z3g4s3w39h1nd293542hl9qv55j29gcr3bkia0rr3ldsppnxh"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v" "numpydoc/tests"
- ;; TODO: unclear why these fail.
- "-k" "not test_MyClass and not test_my_function")))))))
+ (list #:test-flags
+ '(list "numpydoc/tests"
+ ;; TODO: unclear why these fail.
+ "-k" "not test_MyClass and not test_my_function")))
(propagated-inputs (list python-jinja2 python-sphinx))
(native-inputs (list python-matplotlib python-pytest python-pytest-cov))
(home-page "https://pypi.org/project/numpydoc/")