aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2025-01-06 10:29:45 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:23:03 +0200
commitfc1fd14963f4c1eaa11cc71ac270a467b1e22dc7 (patch)
tree3ba5fbf20d23174709c17edc85ba28aca2f2daa4
parent76b64dcb09c7c3116d730c269d0a0efe188729b1 (diff)
downloadguix-fc1fd14963f4c1eaa11cc71ac270a467b1e22dc7.tar.gz
guix-fc1fd14963f4c1eaa11cc71ac270a467b1e22dc7.zip
gnu: Add rust-globwalk-0.9.
* gnu/packages/crates-io.scm (rust-globwalk-0.9): New variable. (rust-globwalk-0.8): Inherit from rust-globwalk-0.9. Change-Id: I52523d4cdc3f9e389f8fabbaacc984c7392b54be
-rw-r--r--gnu/packages/crates-io.scm37
1 files changed, 28 insertions, 9 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 52a03671f1..30592f46c3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29873,8 +29873,35 @@ the process of matching one or more glob patterns against a single candidate
path simultaneously, and returning all of the globs that matched.")
(license (list license:expat license:unlicense))))
+(define-public rust-globwalk-0.9
+ (package
+ (name "rust-globwalk")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "globwalk" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0mz7bsa66p2rrgnz3l94ac4kbklh7mq8j30iizyxjy4qyvmn1xqb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-bitflags" ,rust-bitflags-2)
+ ("rust-ignore" ,rust-ignore-0.4)
+ ("rust-walkdir" ,rust-walkdir-2))
+ #:cargo-development-inputs (("rust-docmatic" ,rust-docmatic-0.1)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/gilnaa/globwalk")
+ (synopsis "Glob-matched recursive file system walking")
+ (description "This package provides glob-matched recursive file system
+walking. Based on both @code{rust-walkdir} and @code{rust-ignore}, this crate
+inherits many goodies from both, such as limiting search depth and amount of
+open file descriptors.")
+ (license license:expat)))
+
(define-public rust-globwalk-0.8
(package
+ (inherit rust-globwalk-0.9)
(name "rust-globwalk")
(version "0.8.1")
(source
@@ -29889,7 +29916,6 @@ path simultaneously, and returning all of the globs that matched.")
'(begin (substitute* "Cargo.toml"
(("\"=([[:digit:]]+(\\.[[:digit:]]+)*)" _ version)
(string-append "\"^" version)))))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-bitflags" ,rust-bitflags-1)
@@ -29898,14 +29924,7 @@ path simultaneously, and returning all of the globs that matched.")
#:cargo-development-inputs
(("rust-backtrace" ,rust-backtrace-0.3)
("rust-docmatic" ,rust-docmatic-0.1)
- ("rust-tempdir" ,rust-tempdir-0.3))))
- (home-page "https://github.com/gilnaa/globwalk")
- (synopsis "Glob-matched recursive file system walking")
- (description "This package provides glob-matched recursive file system
-walking. Based on both @code{rust-walkdir} and @code{rust-ignore}, this crate
-inherits many goodies from both, such as limiting search depth and amount of
-open file descriptors.")
- (license license:expat)))
+ ("rust-tempdir" ,rust-tempdir-0.3))))))
(define-public rust-gloo-timers-0.3
(package