aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 19:41:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:16 +0200
commitfc11ada0ec8b7c288a463e0e6a6edeb479dc5089 (patch)
tree6156535c3943fe48ebfff591d2bc2b8481dc13eb
parent13c9e43840a6abf6dea850720c20c850f61b5a1b (diff)
downloadguix-fc11ada0ec8b7c288a463e0e6a6edeb479dc5089.tar.gz
guix-fc11ada0ec8b7c288a463e0e6a6edeb479dc5089.zip
gnu: Add texlive-bibexport.
* gnu/packages/tex.scm (texlive-bibexport): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 12745b576e..6b37373c0a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3333,6 +3333,29 @@ as a standalone command line tool.")
multiscript version of @code{biblatex-ms}.")
(license license:artistic2.0)))
+(define-public texlive-bibexport
+ (package
+ (name "texlive-bibexport")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/bibexport/"
+ "doc/bibtex/bibexport/" "scripts/bibexport/"
+ "source/bibtex/bibexport/")
+ (base32
+ "161056627w1lazfpld3lyjwfrl8j8gc4b6dzml46bzwf7mk9ifln")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "bibexport.sh")))
+ (home-page "https://ctan.org/pkg/bibexport")
+ (synopsis "Extract a BibTeX file based on a @file{.aux} file")
+ (description
+ "This package provides a Bourne shell script that uses BibTeX to extract
+bibliography entries that are @code{\\cite}'d in a document. It can also
+expand a BibTeX file, expanding the abbreviations (other than the built-in
+ones like month names) and following the cross-references.")
+ (license license:lppl1.3+)))
+
(define-public texlive-bibleref
(package
(name "texlive-bibleref")