aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:06:40 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commitfbe4941c6e19aab05ba7b32988bc75c7d5b698cd (patch)
treeb9355dc05cd0b8ed75f5f7c39d620d65be7fed39
parent0a4a6f23fbe8c7828110b7facb6cf9c81e90d31d (diff)
downloadguix-fbe4941c6e19aab05ba7b32988bc75c7d5b698cd.tar.gz
guix-fbe4941c6e19aab05ba7b32988bc75c7d5b698cd.zip
gnu: Add go-github-com-openhistogram-circonusllhist.
* gnu/packages/golang-xyz.scm (go-github-com-openhistogram-circonusllhist): New variable. Change-Id: I02af4ee4552fe6d09e6727afe6e9098eba0bc0d0
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e6e9d8558d..0e5adb80da 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -5936,6 +5936,31 @@ levels per backend and logger.")
specification-runtime-spec.")
(license license:asl2.0)))
+(define-public go-github-com-openhistogram-circonusllhist
+ (package
+ (name "go-github-com-openhistogram-circonusllhist")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openhistogram/circonusllhist")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ngngjzl3nd30csqvp0gp2qa1hsskl3rh4fgslygvf4p34s42jxk"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/openhistogram/circonusllhist"))
+ (home-page "https://github.com/circonus-labs/circonusllhist")
+ (synopsis "OpenHistogram log-linear histograms in Golang")
+ (description
+ "Package circllhist provides an implementation of Circonus fixed
+log-linear histogram data structure. This allows tracking of histograms in a
+composable way such that accurate error can be reasoned about.")
+ (license license:bsd-3)))
+
(define-public go-github-com-openprinting-goipp
(package
(name "go-github-com-openprinting-goipp")