aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 22:18:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 22:18:47 +0100
commitfbe4643ea3f7a62b797d5c843a11a5d80a955222 (patch)
treee3014516e6d521251ac77e2ffee7abef17b74ccb
parent9b4b9bd92889bc89c7a7c7ba4559f2c4e966f778 (diff)
downloadguix-fbe4643ea3f7a62b797d5c843a11a5d80a955222.tar.gz
guix-fbe4643ea3f7a62b797d5c843a11a5d80a955222.zip
gnu: go-github-com-libp2p-go-flow-metrics: Update to 0.1.0.
* gnu/packages/golang.scm (go-github-com-libp2p-go-flow-metrics): Update to 0.1.0. [propagated-inputs]: Add go-github-com-benbjohnson-clock. Change-Id: I13799b39e8d22a4f1be763eeef24dd2170d1cba1
-rw-r--r--gnu/packages/golang.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index abaa8b2c8f..388ce47ca3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4291,32 +4291,32 @@ generation features. This code generation is used to achieve:
(license license:bsd-3)))
(define-public go-github-com-libp2p-go-flow-metrics
- (let ((commit "7e5a55af485341567f98d6847a373eb5ddcdcd43")
- (revision "0"))
(package
(name "go-github-com-libp2p-go-flow-metrics")
- (version (git-version "0.2.0" revision commit))
+ (version "0.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/libp2p/go-flow-metrics")
- (commit commit)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1p87iyk6q6f3g3xkncssx400qlld8f2z93qiz8m1f97grfyhjif1"))))
+ "13yb68vrcn2zdi0mjjh17dphfxl6y99bkq0ia53hasyfj6l6626h"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/libp2p/go-flow-metrics"
;; TODO: Tests hang.
#:tests? #f))
+ (propagated-inputs
+ (list go-github-com-benbjohnson-clock))
(home-page
"https://github.com/libp2p/go-flow-metrics")
(synopsis "Simple library for tracking flow metrics")
(description "A simple alternative to rcrowley's @command{go-metrics}
that's a lot faster (and only does simple bandwidth metrics).")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-btcsuite-btclog
(let ((commit "84c8d2346e9fc8c7b947e243b9c24e6df9fd206a")