aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Quandour <adam.quandour@gmail.com>2024-07-27 16:59:06 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 00:33:34 +0100
commitfb2347f6d161db0c0ec5fd8fd952ab8cdb7c2738 (patch)
tree2371f6554570e6d38ad6a1f5f70ac624cd0a41d7
parent9eac01173c0664659d73a134fe6489289af0e3d5 (diff)
downloadguix-fb2347f6d161db0c0ec5fd8fd952ab8cdb7c2738.tar.gz
guix-fb2347f6d161db0c0ec5fd8fd952ab8cdb7c2738.zip
gnu: Add go-github-com-anaskhan96-soup.
* gnu/packages/golang-web.scm (go-github-com-anaskhan96-soup): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 08bab36ca7..2080604c24 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -210,6 +210,34 @@ required dependencies. The HTTP response contains the aggregated health
result and details about the health status of each component.")
(license license:expat)))
+(define-public go-github-com-anaskhan96-soup
+ (package
+ (name "go-github-com-anaskhan96-soup")
+ (version "1.2.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/anaskhan96/soup")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s19119sy4zqf05sgpdymcbdaz5bg86n7xwgd2m1vvxjmp485k5p"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/anaskhan96/soup"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-net))
+ (home-page "https://github.com/anaskhan96/soup")
+ (synopsis "Web Scraper in Go, similar to BeautifulSoup")
+ (description
+ "Small web scraper package for Go, with its interface highly similar to
+that of BeautifulSoup.")
+ (license license:expat)))
+
(define-public go-github-com-andybalholm-cascadia
(package
(name "go-github-com-andybalholm-cascadia")