aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-12 21:51:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:57 +0200
commitfb1c04d05e7c8be9d068ee6af197da6cce5c4b54 (patch)
tree4994e7f9966c8a07cf82c3d65ecb6e84de54aa4b
parent43f405a6c5fba468af192193065316e2f044dee9 (diff)
downloadguix-fb1c04d05e7c8be9d068ee6af197da6cce5c4b54.tar.gz
guix-fb1c04d05e7c8be9d068ee6af197da6cce5c4b54.zip
gnu: Add texlive-asypictureb.
* gnu/packages/tex.scm (texlive-asypictureb): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 74b169a619..e454ae7d70 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16068,6 +16068,31 @@ to process one picture at a time, in simple test documents, and then to
migrate (with no fuss) to their use in the target document.")
(license license:lppl)))
+(define-public texlive-asypictureb
+ (package
+ (name "texlive-asypictureb")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/asypictureb/"
+ "source/latex/asypictureb/"
+ "tex/latex/asypictureb/")
+ (base32
+ "1djlphr3iz0l0x2pf8abd251q78rml6435f6ng7fa553anwgwya9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/asypictureb")
+ (synopsis "User-friendly integration of Asymptote into LaTeX")
+ (description
+ "The package is an unofficial alternative to the package provided with
+the Asymptote distribution, for including pictures within a LaTeX source file.
+While it does not duplicate all the features of the official package, this
+package is more user-friendly in several ways. Most notably, Asymptote errors
+are repackaged as LaTeX errors, making debugging less of a pain. It also has
+a more robust mechanism for identifying unchanged pictures that need not be
+recompiled.")
+ (license license:lppl1.3+)))
+
(define-public texlive-auto-pst-pdf-lua
(package
(name "texlive-auto-pst-pdf-lua")