aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-06-28 05:47:48 -0400
committerMark H Weaver <mhw@netris.org>2018-06-28 05:47:48 -0400
commitfa41a089a1713601648664242530a55b6f6b1d0c (patch)
treea375a9892e62e7f9a915e78b2d121092f9d1d36e
parent2c8ac3641a673328d19677f8c8f2ebf690ad3c0e (diff)
downloadguix-fa41a089a1713601648664242530a55b6f6b1d0c.tar.gz
guix-fa41a089a1713601648664242530a55b6f6b1d0c.zip
gnu: icedtea-7: Return #t from custom check phase.
* gnu/packages/java.scm (icedtea-7)[arguments]: Return #t from custom check phase.
-rw-r--r--gnu/packages/java.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 043696ca98..747edc18d0 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1330,7 +1330,8 @@ bootstrapping purposes.")
(when #f ; skip tests
(run-test "check-hotspot")
(run-test "check-langtools")
- (run-test "check-jdk")))))
+ (run-test "check-jdk"))
+ #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((doc (string-append (assoc-ref outputs "doc")
td>transformations: '--with-source' now operates in depth....The '--with-source' option is the first one that was implemented, and it's the only one that would operate only on leaf packages rather than traversing the dependency graph. This change makes it consistent with the rest of the transformation options. * guix/transformations.scm (evaluate-source-replacement-specs): New procedure. (transform-package-source): Rewrite using it. * tests/transformations.scm ("options->transformation, with-source, no matches"): Rewrite since we no longer get a warning. ("options->transformation, with-source, in depth"): New test. * doc/guix.texi (Package Transformation Options): Adjust examples. Ludovic Courtès 2022-05-05transformations: Preserve transformation order in package property....Fixes <https://issues.guix.gnu.org/54942>. Reported by SeerLite <seerlite@nixnet.email>. * guix/transformations.scm (options->transformation) [package-with-transformation-properties]: Add call to 'reverse'. * tests/transformations.scm ("options->transformation, property order"): New test. Ludovic Courtès 2022-01-01transformations: Add '--tune'....* guix/transformations.scm (tuning-compiler) (tuned-package, tunable-package?, package-tuning) (transform-package-tuning) (build-system-with-tuning-compiler): New procedures. (%transformations): Add 'tune'. (%transformation-options): Add "--tune". * tests/transformations.scm ("options->transformation, tune") ("options->transformations, tune, wrong micro-architecture"): New tests. * doc/guix.texi (Package Transformation Options): Document '--tune'. Ludovic Courtès 2021-09-08transformations: Git tags and 'git describe' style IDs are used as version....* guix/transformations.scm (commit->version-string): New procedure. Use git tags and 'git describe' style identifiers directly. (transform-package-source-commit): Adjust accordingly. * tests/transformations.scm ("options->transformation, with-commit, version transformation"): New test. * doc/guix.texi (Package Transformation Options): Mention the 'git describe' style. Marius Bakke 2021-08-11transformations: 'with-patch' works on non-origin sources....Fixes <https://issues.guix.gnu.org/49697>. Reported by Philippe Swartvagher <philippe.swartvagher@inria.fr>. * guix/transformations.scm (patched-source): New procedure. (transform-package-patches)[package-with-extra-patches]: Use it when (package-source p) is not an origin. * tests/transformations.scm ("options->transformation, with-commit + with-patch"): New test. Ludovic Courtès