aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-01-25 13:10:47 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-01-25 13:10:47 +0000
commitf9ea212e912e5263cc188df1dec764881adf5437 (patch)
tree64fee0409a9f4b650c9125f4b2af53633d7ac7c8
parent82362e5c70adaaf748974790555885dd2b2165b7 (diff)
downloadguix-f9ea212e912e5263cc188df1dec764881adf5437.tar.gz
guix-f9ea212e912e5263cc188df1dec764881adf5437.zip
gnu: go-github-com-sabhiram-go-gitignore: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-sabhiram-go-gitignore): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ie137f390626b89b980833091f641700fa4d6f504
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index fee2f77225..1ce22e8d82 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -13088,6 +13088,30 @@ logging.")
"This package implements column-formatted output for Golang.")
(license license:expat)))
+(define-public go-github-com-sabhiram-go-gitignore
+ (package
+ (name "go-github-com-sabhiram-go-gitignore")
+ (version "0.0.0-20210923224102-525f6e181f06")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sabhiram/go-gitignore")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "197giv3snczvbihzvkja5pq53yw5fc516rnjm71hni8gawb8jmh3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/sabhiram/go-gitignore"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/sabhiram/go-gitignore")
+ (synopsis "Gitignore parser for Go")
+ (description "A @command{.gitignore} parser for Go.")
+ (license license:expat)))
+
(define-public go-github-com-sahilm-fuzzy
(package
(name "go-github-com-sahilm-fuzzy")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a5c4637d02..799dca5c91 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2067,31 +2067,6 @@ be performed.")
(description "Go wrapper for taglib")
(license license:unlicense))))
-(define-public go-github-com-sabhiram-go-gitignore
- (package
- (name "go-github-com-sabhiram-go-gitignore")
- (version "0.0.0-20210923224102-525f6e181f06")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/sabhiram/go-gitignore")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "197giv3snczvbihzvkja5pq53yw5fc516rnjm71hni8gawb8jmh3"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path
- "github.com/sabhiram/go-gitignore"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (home-page "https://github.com/sabhiram/go-gitignore")
- (synopsis "Gitignore parser for Go")
- (description "A @command{.gitignore} parser for Go.")
- (license license:expat)))
-
(define-public go-github-com-go-md2man
(package
(name "go-github-com-go-md2man")