aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2023-02-03 07:43:07 -0500
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:32 +0200
commitf98d63d0b1ff12c55540170ec5857d4284948801 (patch)
treebba43f0f4a64e2eb01da8b880a0fe8a304ef00ea
parent659f37fcbf766e55f32906cda3a054b87382eca2 (diff)
downloadguix-f98d63d0b1ff12c55540170ec5857d4284948801.tar.gz
guix-f98d63d0b1ff12c55540170ec5857d4284948801.zip
gnu: font-comic-neue: Install license file.
* gnu/packages/fonts.scm (font-comic-neue)[arguments]<#:phases>: Add "enter-license-directory" phase.
-rw-r--r--gnu/packages/fonts.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 4c48aa24d7..0fd5be8788 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1858,8 +1858,7 @@ later hand-tweaked with the gbdfed(1) editor:
;; several hidden files to be installed.
(add-before 'install 'delete-macosx-files
(lambda _
- (delete-file-recursively "__MACOSX")
- #t))
+ (delete-file-recursively "__MACOSX")))
(add-after 'install 'install-conf
(lambda* (#:key outputs #:allow-other-keys)
(let ((conf-dir (string-append (assoc-ref outputs "out")
@@ -1878,8 +1877,10 @@ later hand-tweaked with the gbdfed(1) editor:
<family>Comic Neue</family>
</prefer>
</alias>
-</fontconfig>\n"))))
- #t)))))
+</fontconfig>\n"))))))
+ (add-before 'install-license-files 'enter-license-directory
+ (lambda _
+ (chdir (string-append "comic-neue-" ,version)))))))
(home-page "https://www.comicneue.com/")
(synopsis "Font that fixes the shortcomings of Comic Sans")
(description