aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@friendly-machines.com>2024-09-01 17:58:49 +0200
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-09-01 18:05:09 +0200
commitf88a946249d75b9e8fa310471e7f2fec91d9790b (patch)
tree2d935b3ce05df8c887efeab4d001be041ecca84d
parente1c92c98f7afff13fb7060199ba0dd4d9c5c2c53 (diff)
downloadguix-f88a946249d75b9e8fa310471e7f2fec91d9790b.tar.gz
guix-f88a946249d75b9e8fa310471e7f2fec91d9790b.zip
gnu: Add emacs-outline-indent.
* gnu/packages/emacs-xyz.scm (emacs-outline-indent): New variable. Change-Id: I18c4c44630ecac79df384952c38492511c626650
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6c338329f2..370daaf50e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31274,6 +31274,30 @@ transparently adjusts the corresponding settings in Emacs, making it more
convenient to edit foreign files.")
(license license:gpl2+)))
+(define-public emacs-outline-indent
+ (package
+ (name "emacs-outline-indent")
+ (version "1.0.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jamescherti/outline-indent.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n6k3cjacb9pqhykbxl75jli6770cb0cfc2gmjx8xkhj4yrhb5nn"))))
+ (build-system emacs-build-system)
+ (synopsis "Outline and code folding for indentation-based texts in Emacs")
+ (description "This package provides a minor mode that enables code folding
+based on indentation levels for various indentation-based text files, such as
+YAML, Python, and any other indented text files. In addition to code folding,
+outline-indent allows moving indented subtrees up and down, promoting and
+demoting sections to adjust indentation levels, customizing the ellipsis, and
+inserting a new line with the same indentation level as the current line.")
+ (home-page "https://github.com/jamescherti/outline-indent.el")
+ (license license:gpl3+)))
+
(define-public emacs-repo
(package
(name "emacs-repo")