aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2025-03-07 10:32:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-03-07 12:03:47 +0200
commitf634fc01ef79d541441c7391ca9f52c71e7748c7 (patch)
tree18a812aab02670d24099a840ea61ebf039bf406b
parent1d5496f2f92b52b24868ec6bfbc1a5e3fdb7480b (diff)
downloadguix-f634fc01ef79d541441c7391ca9f52c71e7748c7.tar.gz
guix-f634fc01ef79d541441c7391ca9f52c71e7748c7.zip
gnu: node-bootstrap: Remove riscv64-linux from supported-systems.
* gnu/packages/node.scm (node-bootstrap)[supported-systems]: New field. (node-lts)[supported-system]: Restore the default. Change-Id: Ia2eb1b18298e6bdb088b3d9d8fa4c395b690253f
-rw-r--r--gnu/packages/node.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 039848b1a4..3d0a86b4fb 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -342,6 +342,7 @@ for easily building fast, scalable network applications. Node.js uses an
event-driven, non-blocking I/O model that makes it lightweight and efficient,
perfect for data-intensive real-time applications that run across distributed
devices.")
+ (supported-systems (delete "riscv64-linux" %supported-systems))
(home-page "https://nodejs.org/")
(license license:expat)
(properties '((max-silent-time . 7200) ;2h, needed on ARM
@@ -990,6 +991,7 @@ fi"
`(,nghttp2 "lib")
openssl
zlib))
+ (supported-systems %supported-systems)
(properties (alist-delete 'hidden? (package-properties node-bootstrap)))))
(define-public node node-lts)