aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:31:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:16 +0200
commitf5fec06954586af3dc14838b854be13a4e65d0a2 (patch)
treedb2343e0998ba6252e5007d387832854bf2b266a
parent3a1e1931b31ec2c757298c19843f56311b2392f4 (diff)
downloadguix-f5fec06954586af3dc14838b854be13a4e65d0a2.tar.gz
guix-f5fec06954586af3dc14838b854be13a4e65d0a2.zip
gnu: Add texlive-fontware.
* gnu/packages/tex.scm (texlive-fontware): New variable.
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e351854f3d..608db1fa67 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1150,6 +1150,35 @@ otc) into individual fonts.
@end itemize")
(license license:gpl2)))
+(define-public texlive-fontware
+ (package
+ (name "texlive-fontware")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/pltotf.1"
+ "doc/man/man1/pltotf.man1.pdf"
+ "doc/man/man1/tftopl.1"
+ "doc/man/man1/tftopl.man1.pdf"
+ "doc/man/man1/vftovp.1"
+ "doc/man/man1/vftovp.man1.pdf"
+ "doc/man/man1/vptovf.1"
+ "doc/man/man1/vptovf.man1.pdf")
+ (base32
+ "0ng27m6cz92aa52z99gnw5i8s8fbkxq4354mygwnchchgxndcba0")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/vfware")
+ (synopsis "Tools for virtual font metrics")
+ (description
+ "Virtual font metrics are usually created in a textual form, the Virtual
+Property List, but programs that use them need to use binary files (the
+Virtual Font and the TeX Font Metric). The two programs provided in this
+package translate between the two forms: @command{vptovf} takes a VPL file and
+generates a VF file and a TFM file; @command{vftovp} takes a VF file and a TFM
+file and generates a VPL file.")
+ (license license:knuth)))
+
(define-public texlive-tex
(package
(name "texlive-tex")