aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-04 12:20:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:14 +0200
commitf581a4b8b51ceb94c42b6f0a982d94a5b61c5a6e (patch)
treebc099c1fa6368afb69fd217efca4ef2ccbe4c1e7
parenta28ccefb28af1f73288e6cf20b9f923ca358cc8d (diff)
downloadguix-f581a4b8b51ceb94c42b6f0a982d94a5b61c5a6e.tar.gz
guix-f581a4b8b51ceb94c42b6f0a982d94a5b61c5a6e.zip
gnu: Add texlive-macros2e.
* gnu/packages/tex.scm (texlive-macros2e): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3e89a3febb..01f80e0637 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4833,6 +4833,27 @@ Short Introduction to LaTeX2e}.")
several languages not included in that package: BUGS, JAGS, and Stan.")
(license license:lppl1.3+)))
+(define-public texlive-macros2e
+ (package
+ (name "texlive-macros2e")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/macros2e/" "tex/latex/macros2e/")
+ (base32
+ "0vdw389gvwmpqs7ykm3vlyqbpwm45mgqasmqyxm7q9jgay3dn2iz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/macros2e")
+ (synopsis "List of internal LaTeX2e macros")
+ (description
+ "This document lists the internal macros defined by the LaTeX2e base files,
+which can also be useful to package authors. The macros are hyper-linked to
+their description in @code{source2e}. For this to work both PDFs must be
+inside the same directory. This document is not yet complete in content and
+format and may miss some macros.")
+ (license license:lppl1.3c)))
+
(define-public texlive-mathcommand
(package
(name "texlive-mathcommand")