aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-10-24 19:33:54 +0000
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:30 +0200
commitf40553702db7f633f4966ae29655c32ee224cd53 (patch)
tree50f4c10210148728d235b99d944ee39fb02bc017
parentba07aad5b33db0cbaa862ffca7f85de26e44b6af (diff)
downloadguix-f40553702db7f633f4966ae29655c32ee224cd53.tar.gz
guix-f40553702db7f633f4966ae29655c32ee224cd53.zip
gnu: boost: Update to 1.83.0.
* gnu/packages/boost.scm (boost): Update to 1.83.0. [source](patches): Add new and remove old upstream patches. (patch-flags): Strip prefix to match source directory structure. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I68d0d50ea916c938d4b30e8e074202a9380cfa0b
-rw-r--r--gnu/packages/boost.scm31
1 files changed, 5 insertions, 26 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 4f032352f3..70774617f0 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -67,7 +67,7 @@
(define-public boost
(package
(name "boost")
- (version "1.80.0")
+ (version "1.83.0")
(source (origin
(method url-fetch)
(uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
@@ -75,33 +75,12 @@
(version-with-underscores version) ".tar.bz2"))
(patches
(list (boost-patch
- ;; Boost.Filesystem directory iterators may fail to
- ;; construct for a network share on Windows prior to 10:
- ;; https://github.com/boostorg/filesystem/pull/246,
- ;; https://github.com/boostorg/filesystem/issues/245
- "0001-filesystem-win-fix-dir-it-net-share.patch" version
- "067hhylqkzzdbqzc1hkbpaqmvz248lxqrdhb2yi6iq9qabsik3lk")
- (boost-patch
- ;; In Boost.Filesystem on Windows, weakly_canonical fails
- ;; to process paths that start with the "\\?\" prefix:
- ;; https://github.com/boostorg/filesystem/issues/247
- "0002-filesystem-fix-weakly-canonical-long-paths.patch" version
- "00w3albf8527glclx85p5b2ml3vr06xpwwmfyzg005v1cp8avcpi")
- (boost-patch
- ;; Boost.Unordered containers are not in a valid state
- ;; after moving:
- ;; https://github.com/boostorg/unordered/issues/139
- "0003-unordered-valid-after-move.patch" version
- "0dw839w22cawqawfpsx7j7v9y0x2vn66m732iidpxvdxbjn2kzva")
- (boost-patch
- ;; Fixed a missing include on POSIX systems that don't
- ;; support *at APIs:
- ;; https://github.com/boostorg/filesystem/issues/250
- "0004-filesystem-posix-fix-no-at-apis-missing-include.patch" version
- "09k8k3b1306jkjls12wfghj820n828j6aaxzmcr0wpnjhp8fzi1v")))
+ "0001-unordered-fix-copy-assign.patch" version
+ "09j61m5xh7099k5na9i43x5rra51znf7vm2nyh89yqpizcll9q66")))
+ (patch-flags '("-p2"))
(sha256
(base32
- "1h00qp4z5k6lfz310xjwsmqs8fwxi6ngas51169cafz4h9fmc68y"))))
+ "13iviiwk1srpw9dmiwabkxv56v0pl0zggjp8zxy1419k5zzfsy34"))))
(build-system gnu-build-system)
(inputs
(append