aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-07-13 14:13:12 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-12 22:51:56 +0100
commitf3a2cf6643433eb9906f1dff7f93c88f25cd527b (patch)
treeac51b87b28286d53bd5949c008fd941e46f4cb93
parentfe7c622ab00afd88d64a5fab32e26ed54ef614ee (diff)
downloadguix-f3a2cf6643433eb9906f1dff7f93c88f25cd527b.tar.gz
guix-f3a2cf6643433eb9906f1dff7f93c88f25cd527b.zip
gnu: glfw-3.4: New variable.
* gnu/packages/gl.scm (glfw-3.4): New variable. Change-Id: I77f2214c78f35455436897a3fbff083331295314 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/gl.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index f40ddaeb86..8441f3ae65 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -995,6 +995,21 @@ desktop computers. It provides a simple API for creating windows, contexts
and surfaces, receiving input and events.")
(license license:zlib)))
+(define-public glfw-3.4
+ (package
+ (inherit glfw)
+ (version "3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/glfw/glfw"
+ "/releases/download/" version
+ "/glfw-" version ".zip"))
+ (sha256
+ (base32
+ "1sd396kkn53myp61kxrd18h7b1q4ix173hhxhvl0iz8j4x5h1v5m"))))
+ (native-inputs (modify-inputs (package-native-inputs glfw)
+ (prepend pkg-config)))))
+
(define-public nanovg-for-extempore
(let ((version "0.7.1")
(revision "0")