aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2025-01-03 15:24:26 +0100
committerLudovic Courtès <ludo@gnu.org>2025-01-19 23:09:54 +0100
commitf3315c3fa8a0b5a9eb74a0e1fc90e848a73fda92 (patch)
treebabf933e9effc143f8a1276f2e3098713ffb3589
parent5e834c220e81fddb77a26e23cf0cd5055b866844 (diff)
downloadguix-f3315c3fa8a0b5a9eb74a0e1fc90e848a73fda92.tar.gz
guix-f3315c3fa8a0b5a9eb74a0e1fc90e848a73fda92.zip
gnu: gnucash: Fix locating perl binary.
It tried to search in the $PATH, that does not really work for Guix. * gnu/packages/gnucash.scm (gnucash)[arguments]<#:phases>: Add set-perl-path. Change-Id: I93468c201de8af3ad76cce945483b76f28ea2749 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnucash.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 71a49b75d6..6df2b76505 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -102,6 +102,11 @@
(substitute* "CMakeLists.txt"
(("set\\(SHELL /bin/bash\\)")
(string-append "set(SHELL " (which "bash") ")")))))
+ (add-after 'unpack 'set-perl-path
+ (lambda _
+ (substitute* "libgnucash/app-utils/gnc-quotes.cpp"
+ (("c_cmd\\{bp::search_path\\(\"perl\"\\)\\}")
+ (format #f "c_cmd{~s}" #$(file-append perl "/bin/perl"))))))
;; The qof test requires the en_US, en_GB, and fr_FR locales.
(add-before 'check 'install-locales
(lambda _