aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-30 20:30:09 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-12-01 14:08:46 +0200
commitf303eaa31b554550b75e46b216d48ca38d0a4e70 (patch)
tree76d1a147b49f017585f464184717ebc4a2049178
parent2eca48e3101cfa7a787732d471a0b77fac07af07 (diff)
downloadguix-f303eaa31b554550b75e46b216d48ca38d0a4e70.tar.gz
guix-f303eaa31b554550b75e46b216d48ca38d0a4e70.zip
gnu: Add julia-jive.
* gnu/packages/julia-xyz.scm (julia-jive): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/julia-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ef9690262b..8449ddcd4b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2673,6 +2673,25 @@ extensions to the iterator interface.")
"Common functional iterator patterns (formerly @code{Iterators.jl}).")
(license license:expat)))
+(define-public julia-jive
+ (package
+ (name "julia-jive")
+ (version "0.2.20")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wookay/Jive.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0khwsdh8472jxcfi9lqw14l49sqlbsixql1jb4irnyajxkdjrcsf"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/wookay/Jive.jl")
+ (synopsis "Julia package to help with writing tests")
+ (description "@code{Jive.jl} is a Julia package to help with writing tests.")
+ (license license:expat)))
+
(define-public julia-json
(package
(name "julia-json")
s/golang.scm?id=72274434a8419d80d036b9e91af50a291cda644c'>gnu: Add go-github-com-andybalholm-brotli....Sharlatan Hellseher 2022-01-28gnu: Add missing module import....Sharlatan Hellseher 2022-01-28gnu: Add go-github-com-vmihailenco-msgpack-v4....Sharlatan Hellseher 2022-01-28gnu: Add go-github-com-hashicorp-hcl-v2....Sharlatan Hellseher 2022-01-28gnu: Add go-github-com-zclconf-go-cty....Sharlatan Hellseher 2022-01-28gnu: Add go-github-com-agext-levenshtein....Sharlatan Hellseher 2022-01-28gnu: Add go-github-com-apparentlymart-go-textseg-v13....Sharlatan Hellseher 2022-01-28gnu: Add go-github-com-vmihailenco-tagparser....Sharlatan Hellseher 2022-01-25Merge branch 'master' into staging....Maxim Cournoyer 2022-01-17Merge branch 'version-1.4.0'...Maxim Cournoyer 2022-01-10gnu: go-github-com-gdamore-tcell: Remove obsolete phase....Sarah Morgensen 2022-01-10gnu: go-github-com-docker-distribution: Remove obsolete phase....Sarah Morgensen 2022-01-10gnu: go-golang-org-x-crypto: Remove obsolete phase....Sarah Morgensen 2022-01-09gnu: Add go-github-com-dreamacro-go-shadowsocks2...Lu Hui 2022-01-09gnu: go-github-com-stretchr-testify: Update to 1.7.0....Efraim Flashner 2022-01-12gnu: go-github-com-muesli-termenv: Update to 0.8.1....Guix Together 2022-01-12gnu: Add go-github-com-muesli-reflow-truncate....Guix Together 2022-01-12gnu: go-github-com-muesli-reflow-wordwrap: Update to 0.3.0....Guix Together 2022-01-12gnu: Add go-github-com-containerd-console....Guix Together 2022-01-12gnu: Add go-github-com-charmbracelet-bubbletea....Guix Together 2022-01-12gnu: go-golang-org-colorful: Update to 1.2.0....Guix Together 2022-01-10gnu: Go 1.17: Update to 1.17.6....Leo Famulari 2022-01-10gnu: Go 1.16: Update to 1.16.13....Leo Famulari 2022-01-06gnu: go-github-com-microcosm-cc-bluemonday: Adjust inputs....Efraim Flashner 2022-01-05gnu: go-github-com-hashicorp-hcl: Update to 1.0.0....Sharlatan Hellseher 2022-01-03gnu: go-github-com-stretchr-objx: Remove vendored code....Efraim Flashner 2022-01-03gnu: go-github-com-fatih-color: Remove vendored code....Efraim Flashner 2022-01-03gnu: go-github-com-chris-ramon-douceur: Adjust inputs....Efraim Flashner 2022-01-02gnu: go-github-com-androiddnsfix: Rename to go-github-com-mtibben-androiddnsfix....Efraim Flashner 2022-01-02gnu: go-github-com-kingpin: Rename to go-github-com-alecthomas-kingpin....Efraim Flashner 2022-01-02gnu: go-github-com-go-libsecret: Rename to go-github-com-gsterjov-go-libsecret....Efraim Flashner 2022-01-02gnu: go-github-com-percent: Rename to go-github-com-mtibben-percent....Efraim Flashner