aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergio Pastor Pérez <sergio.pastorperez@outlook.es>2025-02-27 16:06:24 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2025-02-27 16:06:24 +0100
commitf1810c84f72090b02544ac41d0582c4785728ec4 (patch)
treeaafd7438d8cc0c882a4d77a99cd302390566f758
parent4ead3b607da210b72424b41610e5610e42c17b35 (diff)
downloadguix-f1810c84f72090b02544ac41d0582c4785728ec4.tar.gz
guix-f1810c84f72090b02544ac41d0582c4785728ec4.zip
gnu: Add font-stix-two.
* gnu/packages/fonts.scm (font-stix-two): New variable. Change-Id: I0508879971e648e9ad2d2b9d91e0e1d77bc41fe1 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/fonts.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index d9732281ed..3048289ac0 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -3956,6 +3956,30 @@ The 5x8 and 6x12 versions only contain printable ASCII characters,
Spleen also has support for Powerline symbols out of the box.")
(license license:bsd-2)))
+(define-public font-stix-two
+ (package
+ (name "font-stix-two")
+ (version "2.13b171")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stipub/stixfonts")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17d5a4fk4dz4kraprhxs9q46cbwakfwz06a0qy9zf5nwp4g6fq2d"))))
+ (build-system font-build-system)
+ (home-page "https://www.stixfonts.org/")
+ (synopsis
+ "OpenType Unicode fonts for scientific, technical, and mathematical texts")
+ (description
+ "The mission of the Scientific and Technical Information Exchange (STIX)
+font creation project is the preparation of a comprehensive set of fonts that
+serve the scientific and engineering community in the process from manuscript
+creation through final publication, both in electronic and print formats.")
+ (license license:silofl1.1)))
+
(define-public font-scientifica
(package
(name "font-scientifica")