aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2025-02-17 14:29:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-02-17 14:29:56 +0100
commitf0d4daa13f0b57f5c03af73d449b2c6dd3160d08 (patch)
treec1b091a21c0bb734d68952f92263b58f2f47d84d
parent0fd97df074bc400c9a3580c3666d03d6bd74b187 (diff)
downloadguix-f0d4daa13f0b57f5c03af73d449b2c6dd3160d08.tar.gz
guix-f0d4daa13f0b57f5c03af73d449b2c6dd3160d08.zip
gnu: Add r-redland.
* gnu/packages/cran.scm (r-redland): New variable. Change-Id: I079d09e271c414e204f404fc8fcd2dbf1ea8ee3e
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3d6ea6be28..cec3a1cd71 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -106,6 +106,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages rdf)
#:use-module (gnu packages rust)
#:use-module (gnu packages ssh)
#:use-module (gnu packages sqlite)
@@ -5463,6 +5464,31 @@ convenience functions useful for using CSS selectors on XML nodes. This
package is a port of the Python package @code{cssselect}.")
(license license:bsd-3)))
+(define-public r-redland
+ (package
+ (name "r-redland")
+ (version "1.0.17-18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "redland" version))
+ (sha256
+ (base32 "183m1bvgj52w74383b5v6rfm7gn4izijixans1zdycqp68ibm6g9"))))
+ (properties `((upstream-name . "redland")))
+ (build-system r-build-system)
+ (inputs (list redland pcre2 zlib))
+ (propagated-inputs (list r-roxygen2))
+ (native-inputs (list r-knitr pkg-config r-spelling r-stringi r-testthat))
+ (home-page "https://cran.r-project.org/package=redland")
+ (synopsis "RDF library bindings in R")
+ (description
+ "This package provides methods to parse, query and serialize information
+stored in the @dfn{Resource Description Framework} (RDF). This package
+supports RDF by implementing an R interface to the Redland RDF C library. In
+brief, RDF provides a structured graph consisting of Statements composed of
+Subject, Predicate, and Object Nodes.")
+ (license license:asl2.0)))
+
(define-public r-relations
(package
(name "r-relations")