aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 22:12:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:12 +0200
commitef74e252d735c65393f8a92debf9d3cbc521e816 (patch)
treeb8647e1bc38fa2a480351292286fee0632a8b2e9
parent2682be0aa7614831a9812b67c7c98b93c0932d0a (diff)
downloadguix-ef74e252d735c65393f8a92debf9d3cbc521e816.tar.gz
guix-ef74e252d735c65393f8a92debf9d3cbc521e816.zip
gnu: texlive-standalone: Refresh package definition.
* gnu/packages/tex.scm (texlive-standalone)[source]: Use TEXLIVE-ORIGIN instead of TEXLIVE-REF and SVN-FETCH.
-rw-r--r--gnu/packages/tex.scm52
1 files changed, 32 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 227a365807..391c6956cd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10469,30 +10469,42 @@ keys.")
(package
(name "texlive-standalone")
(version (number->string %texlive-revision))
- (source
- (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "standalone"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "192ydxcn8ir96q8qwvnppksmqf5i0p50i0wz6iqazbwmh3dqxpx4"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/standalone/"
+ "source/latex/standalone/"
+ "tex/latex/standalone/"
+ "tex/plain/standalone/")
+ (base32
+ "00cs6bxpcpl8fjld280af52njkv44fm81yww9ynhqa9xp49q0p90")))
+ (outputs '("out" "doc"))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/standalone"))
- (propagated-inputs
- (list texlive-xkeyval))
(native-inputs
(list texlive-ydoc))
- (home-page "http://www.ctan.org/pkg/standalone")
+ (propagated-inputs
+ (list texlive-adjustbox
+ texlive-currfile
+ texlive-filemod
+ texlive-gincltex
+ texlive-iftex
+ texlive-multido
+ texlive-pdftexcmds
+ texlive-pgf
+ texlive-preview
+ texlive-pstricks
+ texlive-tools
+ texlive-varwidth
+ texlive-xkeyval))
+ (home-page "https://ctan.org/pkg/standalone")
(synopsis "Compile TeX pictures stand-alone or as part of a document")
- (description "A class and package is provided which allows TeX pictures or
-other TeX code to be compiled standalone or as part of a main document.
-Special support for pictures with beamer overlays is also provided. The
-package is used in the main document and skips extra preambles in sub-files.
-The class may be used to simplify the preamble in sub-files. By default the
-@code{preview} package is used to display the typeset code without margins.
-The behaviour in standalone mode may adjusted using a configuration file
-@code{standalone.cfg} to redefine the standalone environment.")
+ (description
+ "This package provides a class and package is provided which allows TeX
+pictures or other TeX code to be compiled standalone or as part of a main
+document. Special support for pictures with @code{beamer} overlays is also
+provided. The package is used in the main document and skips extra preambles
+in sub-files. The class may be used to simplify the preamble in sub-files.
+By default the @code{preview} package is used to display the typeset code
+without margins.")
(license license:lppl1.3+)))
(define-public texlive-siunitx