aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-09-02 22:00:37 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-09-02 22:00:37 +0200
commitedc5808afa26bb231cca9aa2b1d6588830df6300 (patch)
tree076b5e68e477a6519cde5886a455417270f29cde
parent778dd796bff808f1f8520533bab239ecbe83cd87 (diff)
downloadguix-edc5808afa26bb231cca9aa2b1d6588830df6300.tar.gz
guix-edc5808afa26bb231cca9aa2b1d6588830df6300.zip
gnu: gpsbabel: Fix tests.
Qt prints a "Detected locale C with character encoding ANSI_X3.4-1968, which is not UTF-8" warning message when UTF-8 locales are missing, which makes some tests fail. * gnu/packages/gps.scm (gpsbabel)[native-inputs]: Add '(libc-utf8-locales-for-target)'. Change-Id: I3a28912ed07fb7623d6b010d40d7882ebddd52c9
-rw-r--r--gnu/packages/gps.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/gps.scm b/gnu/packages/gps.scm
index 421d828f43..a1333ab758 100644
--- a/gnu/packages/gps.scm
+++ b/gnu/packages/gps.scm
@@ -100,9 +100,22 @@
"-DGPSBABEL_WITH_SHAPELIB=pkgconfig"
"-DGPSBABEL_WITH_ZLIB=pkgconfig")))
(inputs
- (list expat libusb libxkbcommon shapelib qt5compat qtbase qtserialport qttranslations zlib))
+ (list expat
+ libusb
+ libxkbcommon
+ qt5compat
+ qtbase
+ qtserialport
+ qttranslations
+ shapelib
+ zlib))
(native-inputs
- (list which pkg-config qttools libxml2 tzdata-for-tests)) ;'xmllint' needed for the KML tests
+ (list (libc-utf8-locales-for-target)
+ libxml2 ;'xmllint' needed for the KML tests
+ pkg-config
+ qttools
+ tzdata-for-tests
+ which))
(home-page "https://www.gpsbabel.org/")
(synopsis "Convert and exchange data with GPS and map programs")
(description