aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Szmulewicz <daniel.szmulewicz@gmail.com>2024-07-12 17:57:51 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-07-21 13:28:55 +0200
commited96335f06bd9c35f60b8643e251202820ad6aaf (patch)
tree5646374af32f9ed918f15deaa0d44043def5d389
parent3f86edae29ec7a285044bbc293ad7d02b1e843a5 (diff)
downloadguix-ed96335f06bd9c35f60b8643e251202820ad6aaf.tar.gz
guix-ed96335f06bd9c35f60b8643e251202820ad6aaf.zip
gnu: Add emacs-palimpsest
* gnu/packages/emacs-xyz.scm (emacs-palimpsest): New variable. Change-Id: I6e87534db55dd6a03fbcfbc1b13c306c91926343 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a31671a722..ddb43eab9f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1963,6 +1963,28 @@ purpose finder.")
files left by ArchLinux's pacman.")
(license license:expat)))
+(define-public emacs-palimpsest
+ (package
+ (name "emacs-palimpsest")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danielsz/Palimpsest")
+ (commit "f474b3ad706373d9953abdc401d683a2a023d28e")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wzxl1zcbm3svspjpjzvx92is1k9sz7g0a99r8q066j2364la0zh"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/danielsz/Palimpsest")
+ (synopsis "Remove text without permanently deleting it")
+ (description
+ "This minor mode for Emacs provides several strategies to remove text
+without permanently deleting it. Namely, it can send selected test to the
+bottom, or top, of the buffer, or to a trash file.")
+ (license license:gpl3+)))
+
(define-public emacs-minions
(package
(name "emacs-minions")