aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-07-27 11:10:57 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-27 17:53:02 +0200
commited726598fceb8a7bbdf8a1d74f480e5274e3a083 (patch)
tree1337d11b4b84256cdeea5b5ad35341ae4a509be2
parent842517477b763e59edbea2bea62af6319c195711 (diff)
downloadguix-ed726598fceb8a7bbdf8a1d74f480e5274e3a083.tar.gz
guix-ed726598fceb8a7bbdf8a1d74f480e5274e3a083.zip
gnu: klee: Only build on x86_64 Linux.
* gnu/packages/check.scm (klee): Add supported-systems. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/check.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 250206886f..ae3ec90944 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1111,6 +1111,7 @@ with the @code{klee} package.")
(native-inputs (list clang-13 llvm-13 python-lit))
(inputs (list bash-minimal klee-uclibc gperftools sqlite z3 python python-tabulate))
(build-system cmake-build-system)
+ (supported-systems '("x86_64-linux"))
(home-page "https://klee-se.org/")
(synopsis "Symbolic execution engine")
(description "KLEE is a symbolic virtual machine built on top of the LLVM