aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:19:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:14 +0200
commited365bab69e96026629a730ad049eadf5d349829 (patch)
tree7fffe234f1b618795f2f73d5fd1cad3e178046f0
parent338510406311028ee19d6b6da948962436add294 (diff)
downloadguix-ed365bab69e96026629a730ad049eadf5d349829.tar.gz
guix-ed365bab69e96026629a730ad049eadf5d349829.zip
gnu: Add texlive-xltxtra.
* gnu/packages/tex.scm (texlive-xltxtra): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index edf56e7107..7ebafb3056 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2849,6 +2849,33 @@ tables.")
(define-deprecated-package texlive-latex-xcolor texlive-xcolor)
+(define-public texlive-xltxtra
+ (package
+ (name "texlive-xltxtra")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/xelatex/xltxtra/"
+ "source/xelatex/xltxtra/"
+ "tex/xelatex/xltxtra/")
+ (base32
+ "0dh3nnr4xhb85zp3q4jdzqvfghg8m9zvpsvvrmmp0q3ayf0c1dbj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-metalogo))
+ (home-page "https://ctan.org/pkg/xltxtra")
+ (synopsis "Extras for LaTeX users of XeTeX")
+ (description
+ "This package was previously used to provide a number of features that
+were useful for typesetting documents with XeLaTeX. Many of those features
+have now been incorporated into the @code{fontspec} package and other
+packages, but the package persists for backwards compatibility. Nowadays,
+loading @code{xltxtra} will: load the @code{fontspec}, @code{metalogo}, and
+@code{realscripts} packages; redefine @code{\\showhyphens} so it works
+correctly; and define two extra commands: @code{\\vfrac} and
+@code{\\namedglyph}.")
+ (license license:lppl1.3c)))
+
(define-public texlive-xmltexconfig
(package
(name "texlive-xmltexconfig")