aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-11 13:04:03 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:39 +0000
commitecdca86e1ce93ff22b0ad2c40b141b1b0d506418 (patch)
tree4fd87350461eb8f93e8238c339f946f2d41cf72a
parent867d7a8b2f379284295a6388ebe1185d9b23a392 (diff)
downloadguix-ecdca86e1ce93ff22b0ad2c40b141b1b0d506418.tar.gz
guix-ecdca86e1ce93ff22b0ad2c40b141b1b0d506418.zip
gnu: go-1.20: Build with gccgo-12 on some systems.
* gnu/packages/golang.scm (go-1.20)[native-inputs]: Don't replace the gccgo input on architectures bootstrapping go with it. Change-Id: I26831b2bcfe623f6eb0ac7c16b463e5e873110e6 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 971da2b8a3..37e2cd3b96 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016-2023 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016-2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2016, 2019, 2021 Ludovic Courtès <ludo@gnu.org>
@@ -812,7 +812,10 @@ in the style of communicating sequential processes (@dfn{CSP}).")
;; See 'src/cmd/dist/notgo117.go' in the source code distribution,
;; as well as the upstream discussion of this topic:
;; https://go.dev/issue/44505
- (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17)))))
+ ;; We continue to use gccgo-12 since it provides go-1.18.
+ (if (member (%current-system) (package-supported-systems go-1.4))
+ (alist-replace "go" (list go-1.17) (package-native-inputs go-1.17))
+ (package-native-inputs go-1.17)))))
(define-public go-1.21
(package