aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVÖRÖSKŐI András <voroskoi@gmail.com>2024-02-24 21:39:53 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:44:10 +0300
commiteb6e3cbd7760b1c3ae9173181a8c9a490c06b5ab (patch)
treeac97a2187592c519167724e051edbb804c815524
parent5ed847527e33cbdcec75dff09616de01d1a4b5f6 (diff)
downloadguix-eb6e3cbd7760b1c3ae9173181a8c9a490c06b5ab.tar.gz
guix-eb6e3cbd7760b1c3ae9173181a8c9a490c06b5ab.zip
gnu: Add rust-clap-lex-0.7.
* gnu/packages/crates-io.scm (rust-clap-lex-0.7): New variable. (rust-clap-lex-0.6): Inherit from rust-clap-lex-0.7. Change-Id: Id9263095343d39b0cd28271ebe99b0bc6be65b91 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a34fb4312a..70a2a23fd6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12642,17 +12642,17 @@ for programs written with Clap.")
with Clap to generate Fig completion scripts.")
(license (list license:expat license:asl2.0))))
-(define-public rust-clap-lex-0.6
+(define-public rust-clap-lex-0.7
(package
(name "rust-clap-lex")
- (version "0.6.0")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "clap_lex" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1l8bragdvim7mva9flvd159dskn2bdkpl0jqrr41wnjfn8pcfbvh"))))
+ (base32 "1kh1sckgq71kay2rrr149pl9gbsrvyccsq6xm5xpnq0cxnyqzk4q"))))
(build-system cargo-build-system)
(home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
(synopsis "Command line parser for Clap")
@@ -12663,6 +12663,19 @@ stream of tokens.")
;; The user can choose either license.
(license (list license:expat license:asl2.0))))
+(define-public rust-clap-lex-0.6
+ (package
+ (inherit rust-clap-lex-0.7)
+ (name "rust-clap-lex")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "clap_lex" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1l8bragdvim7mva9flvd159dskn2bdkpl0jqrr41wnjfn8pcfbvh"))))))
+
(define-public rust-clap-lex-0.5
(package
(inherit rust-clap-lex-0.6)