aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-09 11:53:46 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:49:43 +0100
commiteaa8d300fec7c6f694ded97132acae463761e6e9 (patch)
tree22a15370bd243da04f78879bcaf719c943eb8e49
parent3729bb7cdd3283b55ed9ef2a3085f572d02f7ecb (diff)
downloadguix-eaa8d300fec7c6f694ded97132acae463761e6e9.tar.gz
guix-eaa8d300fec7c6f694ded97132acae463761e6e9.zip
gnu: Add rust-send-wrapper-0.4.
* gnu/packages/crates-io.scm (rust-send-wrapper-0.4): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8f512aac7d..ff2c3bfbfe 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -31896,6 +31896,29 @@ macOS and iOS.")
(base32
"18vhypw6zgccnrlm5ps1pwa0khz7ry927iznpr88b87cagr1v2iq"))))))
+(define-public rust-send-wrapper-0.4
+ (package
+ (name "rust-send-wrapper")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "send_wrapper" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1l7s28vfnwdbjyrrk3lx81jy4f0dcrv4iwyah2wj6vndxhqxaf7n"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/thk1/send_wrapper")
+ (synopsis "Wrapper moving around non-@code{Send} types between threads")
+ (description
+ "This Rust library implements a wrapper type called @code{SendWrapper}
+which allows you to move around non-@code{Send} types between threads, as long
+as you access the contained value only from within the original thread. You
+also have to make sure that the wrapper is dropped from within the original
+thread. If any of these constraints is violated, a panic occurs.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-sequoia-openpgp-0.9
(package
(name "rust-sequoia-openpgp")